Tps
Benelli Motorcycle Forum - Benelli Bike Discussions - Powered by vBulletin
Results 1 to 6 of 6

Thread: Tps

  1. #1
    Member
    Member #
    18703
    Join Date
    Sep 2018
    Posts
    40

    Tps

    TNT 899S
    If the TPS fails, would it prevent the bike from re-starting, and if so, would it kill the spark or just prevent the injectors from working?
    I have read an article on here by a JohnnyO from Sept 2005 and all the symptoms he listed of a failed TPS apply to my bike, just that after my motor stopped running it lost its spark, making me think the ECU had failed.

  2. #2
    Senior Member Rick67's Avatar
    Name
    Rick
    Member #
    16761
    Join Date
    Sep 2017
    Location
    Brynamman ,Wales
    Posts
    506
    That's possible I guess ..mine had a dead spot at where the 5% throttle position would of been , my bike ran a bit rough in that area until I adjusted to position of it to eliminate it .

  3. #3
    GBo
    GBo is offline
    Senior Member
    Member #
    18749
    Join Date
    Oct 2018
    Location
    Cumbria
    Posts
    224
    I would think if the voltage is either 0 or 5v then it might not find the fuelling or ignition on the map to suit and so not run. Put it on tuneecu and see what it’s doing.

  4. Remove Advertisements
    BenelliForum.com
    Advertisements
     

  5. #4
    Junior Member George1's Avatar
    Member #
    18811
    Join Date
    Nov 2018
    Posts
    21

    Tps

    My bike has done the same, in diagnostics it says that coils and injectors are ground, Ignition varies between -1.0 and 8.7 and injection pulse between 1.995 - 6.581 and the injector relay is getting hot

  6. #5
    Member
    Member #
    18703
    Join Date
    Sep 2018
    Posts
    40
    Quote Originally Posted by GBo View Post
    I would think if the voltage is either 0 or 5v then it might not find the fuelling or ignition on the map to suit and so not run. Put it on tuneecu and see what it’s doing.
    when it stopped running we lost the Tuneecu connection so we cant interrogate it.

  7. #6
    GBo
    GBo is offline
    Senior Member
    Member #
    18749
    Join Date
    Oct 2018
    Location
    Cumbria
    Posts
    224
    That’s not good. Try ecu Recovery it explains on the tuneecu site. Obviously check all fuses and relays. I wouldn’t think a TPS problem would stop ecu communications. The manual explains testing the TPS with a multimeter.

Sponsors

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Google+