250 2c running
Benelli Motorcycle Forum - Benelli Bike Discussions - Powered by vBulletin
Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: 250 2c running

  1. #1
    Senior Member
    Name
    ron daly
    Member #
    8648
    Join Date
    Feb 2009
    Location
    newcastle upon tyne
    Posts
    793

    250 2c running

    Hi, at last got out and had a good run around on my 250, 1 slight problem is all gears rev nicely except top gear, it starts accelerating ok then feels as if it is being strangled, i run on 20;1 mix as the handbook states but have been told that with the newer better 2-stroke oils i should be on about 30:1 mix. It does run quite smoky ( cloud may be better). Anyone have any idea about the 2-stroke mix, cheers, ron d

  2. #2
    Senior Member ferret's Avatar
    Name
    ferret
    Member #
    2383
    Join Date
    Dec 2007
    Location
    ely
    Posts
    1,603
    We used to run 25-1 in all our race engines with newer oils .Pulling clean in top sounds like a mixture/fuel issue to me .I would suggest doing a plug chop flat out in 3rd gear and if the centre is a rich tea biscuit colour you wont be far off.If the exhaust are of original design and are partially blocked with oil etc this can effect peak revs quite drastically especially in 4th and 5th gear .To see if its a pipe issue we would run without the baffles in for a short run ,if it was better you know they and the baffles need a good clean up .If the air filter is dirty or old this can also effect in the same way and makes it feel boggy at higher revs as the air restriction makes it basically like putting the choke on when warm .

  3. #3
    Senior Member dobbinuk's Avatar
    Name
    Lee Hardy
    Member #
    10139
    Join Date
    Apr 2010
    Location
    Ringwood, UK.
    Posts
    2,529
    I would play it safe and stick to 25:1. How old is the fuel oil mix? If left for a long time the fuel might evaporate, leaving a more oily mix. Might be worth looking to see if someone has changed the main jets.

  4. Remove Advertisements
    BenelliForum.com
    Advertisements
     

  5. #4
    Senior Member
    Name
    ron daly
    Member #
    8648
    Join Date
    Feb 2009
    Location
    newcastle upon tyne
    Posts
    793
    Thanks for the replies guy's, i will look into a new air filter and check jets etc, ron d

  6. #5
    Senior Member
    Name
    ron daly
    Member #
    8648
    Join Date
    Feb 2009
    Location
    newcastle upon tyne
    Posts
    793
    Well just been out for a run and the bike is definately running better, i am adding a leaner mix so not at 25:1 yet, will do another plug chop after the tank has been refreshed with the leaner mix and see how it is going, again thanks for the replies, ron d

  7. #6
    Member
    Name
    Tony
    Member #
    9962
    Join Date
    Feb 2010
    Location
    South Australia
    Posts
    96
    Hi Ron,

    Apologies - I only just spotted your posting from earlier this month. My mates and I have now rebuilt four 2Cs and after the run-in period we've changed them all over to fully synthetic Motul two stroke oil running at 50:1.

    So far, after 12 months, we've had no apparent ill effects at all. I have to say we were given a lot of conflicting information but in the end decided to run-in on mineral oil at the recommended ratio and switch to synthetic once the bikes were bedded in.

    They all showed the same problem as yours - sort of "bogging down" when you opened the throttle. New filters had been fitted so we presumed they were too rich and dropped the needles a notch (one notch higher up). Fixed the issue instantly.

    Hope this helps.

    Cheers,

    Tony,
    South Australia

  8. #7
    Senior Member
    Name
    ron daly
    Member #
    8648
    Join Date
    Feb 2009
    Location
    newcastle upon tyne
    Posts
    793
    I am now running on 30:1 and it is running a hell of a lot better, hopefullyout at the Dyke Neuk pub tomorrow so will give it a blast and if still not right i will look at the jets and needles , cheers, ron d

  9. #8
    Senior Member dobbinuk's Avatar
    Name
    Lee Hardy
    Member #
    10139
    Join Date
    Apr 2010
    Location
    Ringwood, UK.
    Posts
    2,529
    Welcome Tony

  10. #9
    Senior Member
    Name
    ron daly
    Member #
    8648
    Join Date
    Feb 2009
    Location
    newcastle upon tyne
    Posts
    793
    Hi and welcome tony, sorry i didn't welcome you when i read your post, i was flicking through at the time posted a reply and bobs your aunt ( what )
    missed it. ron d

  11. #10
    Member
    Name
    Tony
    Member #
    9962
    Join Date
    Feb 2010
    Location
    South Australia
    Posts
    96
    Thanks for the warm welcome guys!

    I'm making the assumption that this is where the "classics" thread of the Benelli forum (on the UK club site) has migrated to. I'd lost it for a while!

    You've possibly seen my 2C restoration blog

    http://www.mistgreen.com/Benelli/index.html


    I haven't updated it for a while but am doing another 2C at the moment and will post some photos when it's completed.

    Cheers to everyone,

    Tony
    South Australia

Page 1 of 2 12 LastLast

Sponsors

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Running on 2 again
    By robin in forum TreK
    Replies: 14
    Last Post: 08-17-2011, 08:29 AM
  2. running on 2
    By ash1000rr in forum Tornado Tre
    Replies: 4
    Last Post: 02-14-2011, 12:50 PM
  3. Running Hot ?
    By katanabandit in forum Tornado Tre
    Replies: 13
    Last Post: 07-18-2009, 12:59 PM
  4. running rich
    By BIANC in forum TNT
    Replies: 2
    Last Post: 07-12-2007, 02:24 PM
  5. Running in....
    By bolero in forum Tornado Tre
    Replies: 31
    Last Post: 06-15-2006, 04:59 AM
Google+