Wanted 1130 walbro ECU
Benelli Motorcycle Forum - Benelli Bike Discussions - Powered by vBulletin
Results 1 to 9 of 9
Like Tree3Likes
  • 3 Post By Rick67

Thread: Wanted 1130 walbro ECU

  1. #1
    Senior Member Rick67's Avatar
    Name
    Rick
    Member #
    16761
    Join Date
    Sep 2017
    Location
    Brynamman ,Wales
    Posts
    857
    I believe my ECU has fried on the injector and coil side of things ..
    .
    Had an issue a couple of weeks back and injector number 3 threw a code , also bike was very slow to spin up on starter.
    Anyway after buying a new set of injectors and then checking and testing all wiring ,sensors, resistance, shorts, breaks ,relays ect . I've drew a blank until I opened up my starter and found the carbon brushes had failed .
    So replaced them with genuine repair kit .
    And tonight I attempted a start up but injector number 2 just kept dumping fuel into the intake. Swapped them over and the same thing happened on number 2.
    Plus no sparks at all ..
    I'm also open to suggestions of other things to check .
    Cheers Rick

  2. #2
    Senior Member StingerWolf's Avatar
    Name
    StingerWolf
    Member #
    2827
    Join Date
    Feb 2008
    Location
    Munich Germany
    Posts
    1,076
    Hi Rick, I have a tested and 100% working Walbro ECU if you need one.

    Gesendet von meinem SM-P905 mit Tapatalk

  3. #3
    GBo
    GBo is offline
    Senior Member
    Member #
    18749
    Join Date
    Oct 2018
    Location
    Cumbria
    Posts
    430
    Bugger. I am thinking that sounds plausible.

  4. Remove Advertisements
    BenelliForum.com
    Advertisements
     

  5. #4
    Senior Member Rick67's Avatar
    Name
    Rick
    Member #
    16761
    Join Date
    Sep 2017
    Location
    Brynamman ,Wales
    Posts
    857

    She's alive !!

    UPDATE....
    fitted the lovely ECU winging it's way to me from Germany just now and up she fires on all three..
    Happy days !!😎.
    All Thanks to Stingerwolf for sending me a superb replacement .🤘

  6. #5
    GBo
    GBo is offline
    Senior Member
    Member #
    18749
    Join Date
    Oct 2018
    Location
    Cumbria
    Posts
    430
    Bugger and I was going to offer you £50 for that non running shed of a bike.😜

  7. #6
    Senior Member Rick67's Avatar
    Name
    Rick
    Member #
    16761
    Join Date
    Sep 2017
    Location
    Brynamman ,Wales
    Posts
    857
    Haha... Glynn It's worth a fiver more than that as it's been to Europe and back 3 times )

  8. #7
    Junior Member George1's Avatar
    Member #
    18811
    Join Date
    Nov 2018
    Posts
    26
    Mine has made it to Perth to Skinner Motorcycles and now starts

  9. #8
    Senior Member Rick67's Avatar
    Name
    Rick
    Member #
    16761
    Join Date
    Sep 2017
    Location
    Brynamman ,Wales
    Posts
    857
    Quote Originally Posted by George1 View Post
    Mine has made it to Perth to Skinner Motorcycles and now starts
    Brilliant news George,
    What was the fix ?

  10. #9
    Junior Member George1's Avatar
    Member #
    18811
    Join Date
    Nov 2018
    Posts
    26
    Quote Originally Posted by Rick67 View Post
    Brilliant news George,
    What was the fix ?

    fuelling/ trim levels, Mike Skinner adjust everything manually and it now works off both power modes. He told me about the Sprag Clutch and suggested a new one. I read on here about the 12 point injectors and he reckons a step in the right direction

Sponsors

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Google+