Benelli TNT 300 cutting off while riding
Benelli Motorcycle Forum - Benelli Bike Discussions - Powered by vBulletin
Results 1 to 6 of 6

Thread: Benelli TNT 300 cutting off while riding

  1. #1
    Junior Member Tonnie's Avatar
    Member #
    19713
    Join Date
    Oct 2019
    Posts
    3

    Unhappy Benelli TNT 300 cutting off while riding

    I am Tonnie currently riding tnt300.She is currently at 25,708Km I am in Kenya. I have this issue which started just yesterday.

    What could be the cause of a bike cutting out while riding.... Then after few minutes it runs well again... After sometimes then it cut out again and runs well after some minutes.
    I checked the fuel filter which is not clogged, changed the plug, new fuel with injector cleaner put in the tank ...but still the problem is there this time it has popped engine check..But the plugs i changed were white in color.


    What is this problem am fighting with?

  2. #2
    Senior Member Rick67's Avatar
    Name
    Rick
    Member #
    16761
    Join Date
    Sep 2017
    Location
    Brynamman ,Wales
    Posts
    622
    Hi .
    Check the side stand switch I had exact same problem . It just needed a tiny spring inside stretched to make a better contact..
    You may also look at your clutch switch as well just in case .
    Have a look at the injector relay too .
    Make sure you don't have a kink in the fuel line that can do it too.
    Have you cleaned your air filter lately.
    Also check your petrol tank breather isn't blocked .
    Hope you cure it .
    Rick
    Last edited by Rick67; 10-22-2019 at 01:45 AM.

  3. #3
    Junior Member Tonnie's Avatar
    Member #
    19713
    Join Date
    Oct 2019
    Posts
    3
    I cleaned the air filter. I will check on stand and clutch swith. I worked on injectors today finished few hrs ago done a short ride. Sounds okey thu not sure if the issue has been resolved

  4. Remove Advertisements
    BenelliForum.com
    Advertisements
     

  5. #4
    Junior Member Tonnie's Avatar
    Member #
    19713
    Join Date
    Oct 2019
    Posts
    3
    Hello friend i ended up using 173USD to replace most fuel and air system. And the problem was just the stand switch.... Thank you friend . I am happy and the riding continues

  6. #5
    Senior Member Rick67's Avatar
    Name
    Rick
    Member #
    16761
    Join Date
    Sep 2017
    Location
    Brynamman ,Wales
    Posts
    622
    Hi Tonnie,
    I'm happy you found the fault in the end.
    Sometimes it's a simple fix that's hard to find 🙂
    Rick

  7. #6
    Senior Member
    Name
    Cam Douglas
    Member #
    18563
    Join Date
    Jul 2018
    Location
    Tasmania
    Posts
    234
    Quote Originally Posted by Tonnie View Post
    Hello friend i ended up using 173USD to replace most fuel and air system. And the problem was just the stand switch...
    I know how you feel. I spent over $200 on new coils when the problem was just a dodgy connector plug.

Sponsors

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Search tags for this page

benelli forum kenya

Click on a term to search our site for related topics.
Google+