Electrics and battery connections - Page 2
Benelli Motorcycle Forum - Benelli Bike Discussions - Powered by vBulletin
Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12

Thread: Electrics and battery connections

  1. #11
    Senior Member Rick67's Avatar
    Name
    Rick
    Member #
    16761
    Join Date
    Sep 2017
    Location
    Brynamman ,Wales
    Posts
    927
    morning Pete,

    have you looked underneath the relay bank behind the Ecu yet?

    i also had to tweak some of the connectors on mine inside the plastic insulator block to make good contacts.

    its also worth removing all the small relays giving them and their connections a clean too if you've not already done it. And swap them around when fitting back in just to see if one or two have become troublesome.

    worth a try

  2. #12
    Senior Member
    Member #
    14194
    Join Date
    Dec 2015
    Posts
    744
    Quote Originally Posted by Rick67 View Post
    morning Pete,

    have you looked underneath the relay bank behind the Ecu yet?

    i also had to tweak some of the connectors on mine inside the plastic insulator block to make good contacts.

    its also worth removing all the small relays giving them and their connections a clean too if you've not already done it. And swap them around when fitting back in just to see if one or two have become troublesome.

    worth a try

    Found it

    The two earth wires from the starter motor stud that holds the relay bracket and then the n/s cover, the single earth wire that disappears into the harness not the main battery return.
    The thing had got hot at sometime and the sheathing had gone brittle, cut that off and the inner wire had cooked and broken. Cut that off , new earth tag soldered on to a new bit of cable and soldered and sleeved into the harness. job done . Have one more to solve, brake lights on, both switches disconnected and brake light permanently on , so must have a cable shorting somewhere. Hey ho its a Benelli, what else would you be doing on a sunday morning .
    Instead of the lights working, together with indicators and dash powering up on the key, the flasher and main beam light were lit up , but nothing else, work that one out !

Page 2 of 2 FirstFirst 12

Sponsors

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Google+