View Profile: Redbaron57 - Benelli Motorcycle Forum - Benelli Bike Discussions
Benelli Motorcycle Forum - Benelli Bike Discussions - Powered by vBulletin
  • Redbaron57's Avatar
    01-11-2021, 04:36 AM
    Hi Cam, an interesting new phenomenon! Nice display! In the Aussie FB group there have been two causes for loss of power. They were 1/. Alternator...
    318 replies | 38354 view(s)
  • Redbaron57's Avatar
    01-08-2021, 07:00 AM
    Rolf, as I connect my 2012 CR to Tune ECU, the headlight turns itself off. So I have never had to pull the fuse. Nigel. Yep. They do but...
    5 replies | 366 view(s)
  • Redbaron57's Avatar
    01-08-2021, 02:29 AM
    What cable are you using? A USB to Serial cable with the FTDI FT232RL chip works for both Windows and Android. I have also used a Prolific PL2303...
    5 replies | 366 view(s)
  • Redbaron57's Avatar
    12-31-2020, 08:39 PM
    Redbaron57 replied to a thread Newby says Hi to all! in TNT
    My TreK alternator drive was in a similar state after 18,500km. In my case the coupling fasteners had not undone but the coupling halves had been...
    23 replies | 571 view(s)
  • Redbaron57's Avatar
    12-27-2020, 02:56 AM
    Redbaron57 replied to a thread 2014 TreK 1130 Stalling in TreK
    Hi GBo, I have the earlier ECU - ECUA1. Maya identifies my ECU as A1BEN_04 but it requires the correct "Device" file to do more than that. I do not...
    10 replies | 495 view(s)
  • Redbaron57's Avatar
    12-25-2020, 04:43 PM
    Redbaron57 replied to a thread 2014 TreK 1130 Stalling in TreK
    I remapped my ECU and adjusted my idle to about 1400 rpm. It is usually OK but it still stalls once in a while when I shut the throttle suddenly. I...
    10 replies | 495 view(s)
No More Results

Statistics


Total Posts
Total Posts
156
Posts Per Day
0.11
General Information
Last Activity
01-11-2021 04:38 AM
Join Date
02-19-2017
Referrals
0
Google+