Tuneecu noob needs advice - Page 2
Benelli Motorcycle Forum - Benelli Bike Discussions - Powered by vBulletin
Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 23
Like Tree2Likes

Thread: Tuneecu noob needs advice

  1. #11
    Senior Member Rick67's Avatar
    Name
    Rick
    Member #
    16761
    Join Date
    Sep 2017
    Location
    Brynamman ,Wales
    Posts
    826
    Quote Originally Posted by GBo View Post
    Alex from maniac says it should be 2 to 4 % open then reset TPS.
    Now that does sound interesting...
    I'll give that a go and see what that produces tomorrow

  2. #12
    Senior Member
    Name
    Daz
    Member #
    19171
    Join Date
    Apr 2019
    Location
    Costa Blanca, Espana
    Posts
    181
    Quote Originally Posted by GBo View Post
    TPS can be done anytime. Alex from maniac says it should be 2 to 4 % open then reset TPS. It’s all a bit vague as the manual is rubbish and more people are knowledgeable on the Sagem. You can’t test the stepper on Walbro.
    Thanks, I'll try that tomorrow.

    I'm a bit tempted to try their remote diagnostic service too.

  3. #13
    Senior Member Rick67's Avatar
    Name
    Rick
    Member #
    16761
    Join Date
    Sep 2017
    Location
    Brynamman ,Wales
    Posts
    826

    2 to 4% TPS then reset ...

    Well I gave it go by adjusting the tickover screw to get to 3% then did the TPS reset .I'm pretty sure that's what was implied .
    Result was dreadful coughing and backfiring into airbox when rolling on throttle. Although I could achieve a very low idle speed About 1100 rpm.
    Needless to say I returned it all back to the way it runs the best .

  4. Remove Advertisements
    BenelliForum.com
    Advertisements
     

  5. #14
    GBo
    GBo is offline
    Senior Member
    Member #
    18749
    Join Date
    Oct 2018
    Location
    Cumbria
    Posts
    382
    I had to set co after that though. The problem that I think you have to know where the stepper is in its range. It would be nice to have a definitive process for setting up the throttle bodies TPS and mixture. I also found that changing the co correction affected the tickover co and had to set it again

    thisis what Alex sent me which worked


    well attached is the MAp for Trek899 Openloop, plz flash it on ecu than reset TPS with Tune ecu
    idle should be between 2-4% tps opening for your Bike, the idle co level should be adjusted to 1,5-2,5% co at watertemp 90-98°
    usually this is around 0,930 in Tune ecu, setting for co correction is 0,945 in Tune ecu and should cause around 4%co at 3000rpm
    that should work good

    ciao Alex


  6. #15
    Senior Member
    Name
    Daz
    Member #
    19171
    Join Date
    Apr 2019
    Location
    Costa Blanca, Espana
    Posts
    181
    I have fitted the standard can today and it seems much better now, I've also arranged for a remote session from Maniac motors

  7. #16
    Senior Member
    Name
    Daz
    Member #
    19171
    Join Date
    Apr 2019
    Location
    Costa Blanca, Espana
    Posts
    181
    A quick update if anyone's interested

    After refitting the original can, I reset the TPS using the method GBo mentioned and it missed & farted, so set everything back as it was, reset the TPS again and it runs beautifully, I'm just waiting for the next problem now

  8. #17
    Senior Member Rick67's Avatar
    Name
    Rick
    Member #
    16761
    Join Date
    Sep 2017
    Location
    Brynamman ,Wales
    Posts
    826
    Dazz,
    We've been waiting with baited breath! ..
    Looks like you had the same result as me then .
    To be fair to Glynn he had done all the other jiggery pokery that came alone with the logarithmic instructions 😂😂

  9. #18
    Senior Member
    Name
    Daz
    Member #
    19171
    Join Date
    Apr 2019
    Location
    Costa Blanca, Espana
    Posts
    181
    Quote Originally Posted by Rick67 View Post
    Dazz,
    We've been waiting with baited breath! ..
    Looks like you had the same result as me then .
    To be fair to Glynn he had done all the other jiggery pokery that came alone with the logarithmic instructions 😂😂
    Lol, good to hear someone cares

    Glynn was also remapping an 899 & I was only trying to smooth my 1130 out. Still got the remote thing with Maniac motors to look forward to as it still smells very rich.

  10. #19
    GBo
    GBo is offline
    Senior Member
    Member #
    18749
    Join Date
    Oct 2018
    Location
    Cumbria
    Posts
    382
    It’s ok I’m not easily offended
    There must be a process that works every time but maybe different between the 899 and 1130. One of the main things I think is the stepper motor then either the bypass opening or throttle opening as between all three enough but not too much air needs to pass or the stepper will be out of its range. Mine has bypass fully closed, and throttle bodies balanced. And I’m not sure if I have ever said this before but the manual sucks.

  11. #20
    Senior Member
    Name
    Daz
    Member #
    19171
    Join Date
    Apr 2019
    Location
    Costa Blanca, Espana
    Posts
    181
    Quote Originally Posted by GBo View Post
    I’m not sure if I have ever said this before but the manual sucks.
    There's a sentence that never needs to be said

Page 2 of 3 FirstFirst 123 LastLast

Sponsors

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Google+