Engine problem - Page 4
Benelli Motorcycle Forum - Benelli Bike Discussions - Powered by vBulletin
Page 4 of 4 FirstFirst 1234
Results 31 to 38 of 38
Like Tree10Likes

Thread: Engine problem

  1. #31
    Senior Member Rick67's Avatar
    Name
    Rick
    Member #
    16761
    Join Date
    Sep 2017
    Location
    Brynamman ,Wales
    Posts
    592
    Quote Originally Posted by JoelC View Post

    I wonder if this might be the start for you? I took mine apart and cleaned all the contacts very carefully and the problem went away. Maybe worth a try?
    Oh nice one Joel !... thats exactly why this forum is such a huge help to us owners 👍
    JoelC likes this.

  2. #32
    Junior Member Rabb's Avatar
    Member #
    14009
    Join Date
    Jun 2015
    Location
    County Durham, UK
    Posts
    29
    Just thought i'd post for information, may help someone in the future. Turns out it was the sidestand switch causing the problem, linked it out last week and done a couple of hundred miles since, running great now .
    Thanks everyone for the input on this problem.
    On another note, had my suspension set up by Ian 'pixie' Pattinson yesterday, can't believe the difference that has made, Nelli is much more planted and confident now. Just need weather to stay dry now.
    RobShed likes this.

  3. #33
    GBo
    GBo is offline
    Senior Member
    Member #
    18749
    Join Date
    Oct 2018
    Location
    Cumbria
    Posts
    264
    Quote Originally Posted by Rabb View Post
    Just thought i'd post for information, may help someone in the future. Turns out it was the sidestand switch causing the problem, linked it out last week and done a couple of hundred miles since, running great now .
    Thanks everyone for the input on this problem.
    On another note, had my suspension set up by Ian 'pixie' Pattinson yesterday, can't believe the difference that has made, Nelli is much more planted and confident now. Just need weather to stay dry now.
    I was talking to him at the St. John’s chapel bike night about setting up mine. Just need to find a time that suits.

  4. Remove Advertisements
    BenelliForum.com
    Advertisements
     

  5. #34
    Senior Member RobShed's Avatar
    Name
    Robin Shedden
    Member #
    15274
    Join Date
    Jan 2017
    Location
    Shrewsbury
    Posts
    327
    Quote Originally Posted by Rabb View Post
    Just thought i'd post for information, may help someone in the future. Turns out it was the sidestand switch causing the problem, linked it out last week and done a couple of hundred miles since, running great now .
    Thanks everyone for the input on this problem.
    On another note, had my suspension set up by Ian 'pixie' Pattinson yesterday, can't believe the difference that has made, Nelli is much more planted and confident now. Just need weather to stay dry now.
    Nice one for reporting this new foible for the Nelly library. Is mpg now improved ? (curve ball from your 1st post)

    And yes, having the suspension set up properly makes a huge difference.

  6. #35
    Junior Member Rabb's Avatar
    Member #
    14009
    Join Date
    Jun 2015
    Location
    County Durham, UK
    Posts
    29
    To be honest, I think mpg is my riding style . I only get 25mpg out of my Transit Custom and an average of around 18mpg out of my Volvo t5.
    RobShed likes this.

  7. #36
    Member - Avatar by MDIB shogun's Avatar
    Name
    Sean (shogun)
    Member #
    1342
    Join Date
    Oct 2007
    Location
    Melbourne Australia
    Posts
    189
    Quote Originally Posted by Rabb View Post
    Just thought i'd post for information, may help someone in the future. Turns out it was the sidestand switch causing the problem, linked it out last week and done a couple of hundred miles since, running great now .
    Thanks everyone for the input on this problem.
    On another note, had my suspension set up by Ian 'pixie' Pattinson yesterday, can't believe the difference that has made, Nelli is much more planted and confident now. Just need weather to stay dry now.
    Hi Rabb
    My Tornado appears to be doing a similar thing, I suspected it might be the stand sensor, what did you do to resolve the issue. Did you disconnect the sensor or replace it.
    Cheers
    Sean

  8. #37
    Senior Member Rick67's Avatar
    Name
    Rick
    Member #
    16761
    Join Date
    Sep 2017
    Location
    Brynamman ,Wales
    Posts
    592
    Sean ,
    Sorry to jump in here,.. but I had the same issue whilst away in Germany it drove me nuts!.
    I took my stand switch apart and it was spotless inside , however there's a tiny spring inside that pushes the contacts and mine had gone weak so I just stretched it a little and it's been fine ever since .4500miles later and it's still good .

  9. #38
    Member - Avatar by MDIB shogun's Avatar
    Name
    Sean (shogun)
    Member #
    1342
    Join Date
    Oct 2007
    Location
    Melbourne Australia
    Posts
    189
    Quote Originally Posted by Rick67 View Post
    Sean ,
    Sorry to jump in here,.. but I had the same issue whilst away in Germany it drove me nuts!.
    I took my stand switch apart and it was spotless inside , however there's a tiny spring inside that pushes the contacts and mine had gone weak so I just stretched it a little and it's been fine ever since .4500miles later and it's still good .
    Awesome thanks for the the intel, ill take a look on the weekend.

Page 4 of 4 FirstFirst 1234

Sponsors

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Replies: 2
    Last Post: 05-08-2018, 01:26 PM
  2. Green paint peeling problem
    By LLOYD BENTON in forum Tornado Tre
    Replies: 4
    Last Post: 01-30-2014, 03:14 PM
  3. engine problem to start
    By SPIROS in forum TNT
    Replies: 3
    Last Post: 02-25-2008, 12:08 PM
  4. TREK - "engine problem"
    By NenadM in forum TreK
    Replies: 0
    Last Post: 09-16-2007, 06:11 PM
  5. Engine Temperature - Wee problem #1
    By DUre in forum Tornado Tre
    Replies: 6
    Last Post: 05-12-2007, 04:01 PM
Google+