No go here either - Page 3
Benelli Motorcycle Forum - Benelli Bike Discussions - Powered by vBulletin
Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 48
Like Tree2Likes

Thread: No go here either

  1. #21
    Member Gads's Avatar
    Member #
    18401
    Join Date
    Jun 2018
    Posts
    50
    Errol. 1,2,3,4,5,and 7 done. Pump is not pumping at all. Fuel flow from gravity only. Ugggh

  2. #22
    Senior Member Engenia's Avatar
    Name
    Errol Kowald
    Member #
    27
    Join Date
    Dec 2006
    Location
    Canberra, ACT, Australia
    Posts
    5,751
    Fortunately, it's a standard pump readily available from Aliexpress for peanuts.
    Before you go down that route though, check the connector inside the tank is up to scratch.
    hooroo, Errol www.engenia.com.au [139,200 km - and counting .....]

  3. #23
    Member Gads's Avatar
    Member #
    18401
    Join Date
    Jun 2018
    Posts
    50
    All connections are good. I'm going to have to cannibalize the green/silver to know for sure.

  4. Remove Advertisements
    BenelliForum.com
    Advertisements
     

  5. #24
    Member Gads's Avatar
    Member #
    18401
    Join Date
    Jun 2018
    Posts
    50
    You mean this one Errol.
    Attached Images Attached Images  

  6. #25
    Member Gads's Avatar
    Member #
    18401
    Join Date
    Jun 2018
    Posts
    50
    Replaced fuel pump and fuel system with injectors from other bike, against my better judgement and fired up straight away. Running great so have ordered new pump and will also put new injectors in green/silver. Thanks for all the help and suggestions. Cheers

  7. #26
    Senior Member Engenia's Avatar
    Name
    Errol Kowald
    Member #
    27
    Join Date
    Dec 2006
    Location
    Canberra, ACT, Australia
    Posts
    5,751
    Quote Originally Posted by Gads View Post
    You mean this one Errol.
    Looks about right. The main differences are the inlet filters supplied, but from memory you can swap your old one onto the new pump.
    The plug supplied (to the pump) won't be needed.
    hooroo, Errol www.engenia.com.au [139,200 km - and counting .....]

  8. #27
    Member Gads's Avatar
    Member #
    18401
    Join Date
    Jun 2018
    Posts
    50
    Cheers Errol. I have ordered it. Do you know the part numbers for the better injectors?

  9. #28
    Senior Member Engenia's Avatar
    Name
    Errol Kowald
    Member #
    27
    Join Date
    Dec 2006
    Location
    Canberra, ACT, Australia
    Posts
    5,751
    There are a number that will do the trick. The last set I got, at the beginning of this year were from Injector Planet in Florida. Denso 297500-0940 I took a stab and it turns out the flow rate was almost perfect - after getting one flow tested.
    I think the Bosch equivalent has the same number, except it starts with a '0'
    There are 10 holes so the atomisation should be superb.
    hooroo, Errol www.engenia.com.au [139,200 km - and counting .....]

  10. #29
    Member Gads's Avatar
    Member #
    18401
    Join Date
    Jun 2018
    Posts
    50
    Cheers matey. That worked and they are on the way.

  11. #30
    Member Gads's Avatar
    Member #
    18401
    Join Date
    Jun 2018
    Posts
    50
    Errol received the injectors from injection planet. They have a different electrical plug shape. He is saying these are the only ones but web site was showing different shape. (Same as the benelli) now has changed the web site. Anyway dont fit, did you have to change the plug on yours? Or does anyone know the replacement number, denso or otherwise

Page 3 of 5 FirstFirst 12345 LastLast

Sponsors

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Google+