TREK 1130 Loud kick when starting or shuting down engine and OBD question
Benelli Motorcycle Forum - Benelli Bike Discussions - Powered by vBulletin
Results 1 to 8 of 8
Like Tree3Likes
  • 1 Post By Oliversb
  • 1 Post By Engenia
  • 1 Post By Rick67

Thread: TREK 1130 Loud kick when starting or shuting down engine and OBD question

  1. #1
    Junior Member
    Member #
    18463
    Join Date
    Jun 2018
    Posts
    3

    TREK 1130 Loud kick when starting or shuting down engine and OBD question

    Hi,

    I just bought a Trek 2008 and i have this strange issue sometimes when starting or shutting down engine i hear this hard hit... anyone have a clue what can it be? One more question, where can i get a obd cable for my trek any suggestions?

    thanks

  2. #2
    Senior Member StingerWolf's Avatar
    Name
    StingerWolf
    Member #
    2827
    Join Date
    Feb 2008
    Location
    Munich Germany
    Posts
    1,040
    Maybe you starter motor is damaged.

    Obd cable dont work with trek.

    If you have a walbro ecu you need a rs232 cable kit have a look at tuneecu.com there are infos how make a cable kit or buy one.

    There are 2 versions out there

    1. rs232 kabel with adapter (sometimes connections is a little unstable)

    2. Usb/amp cable kit (better solution)

    If you want a set let me know I sell them if wanted.

    Gesendet von meinem SM-P905 mit Tapatalk

  3. #3
    Junior Member
    Member #
    18463
    Join Date
    Jun 2018
    Posts
    3
    Quote Originally Posted by StingerWolf View Post
    Maybe you starter motor is damaged.

    Obd cable dont work with trek.

    If you have a walbro ecu you need a rs232 cable kit have a look at tuneecu.com there are infos how make a cable kit or buy one.

    There are 2 versions out there

    1. rs232 kabel with adapter (sometimes connections is a little unstable)

    2. Usb/amp cable kit (better solution)

    If you want a set let me know I sell them if wanted.

    Gesendet von meinem SM-P905 mit Tapatalk
    thx for info... yes im intrested i buying cable... you can send my message with price and details... all i need to do is check is my ecu i walbro... Also i see that you are in Munich i have a friend there who could pick it up and send it to me in croatia...
    StingerWolf likes this.

  4. Remove Advertisements
    BenelliForum.com
    Advertisements
     

  5. #4
    Senior Member StingerWolf's Avatar
    Name
    StingerWolf
    Member #
    2827
    Join Date
    Feb 2008
    Location
    Munich Germany
    Posts
    1,040
    Details sent

    Gesendet von meinem SM-P905 mit Tapatalk

  6. #5
    Junior Member
    Member #
    14857
    Join Date
    Sep 2016
    Posts
    1
    Quote Originally Posted by Oliversb View Post
    Hi,

    I just bought a Trek 2008 and i have this strange issue sometimes when starting or shutting down engine i hear this hard hit... anyone have a clue what can it be? One more question, where can i get a obd cable for my trek any suggestions?

    thanks


    Hi,have you fix the problem with kick? it looks i have the same problem... THX

  7. #6
    Senior Member Engenia's Avatar
    Name
    Errol Kowald
    Member #
    27
    Join Date
    Dec 2006
    Location
    Canberra, ACT, Australia
    Posts
    5,344
    Quote Originally Posted by Oliversb View Post
    i have this strange issue sometimes when starting or shutting down engine i hear this hard hit..
    Same thing sometimes happens with my Tornado, but only at shutdown. It depends where in the cycle the crank stops. There are three (I think) natural resting points dependant on the cam lobes. If it stops between them, the crank will then rapidly move to one. If it means going backwards, it will, and that's where the clunk comes from. The cam chain is running backwards and not held tight by the crank.

    That's my theory. I may be wrong..
    ron d likes this.
    hooroo, Errol www.engenia.com.au [136,351 km - and counting .....]

  8. #7
    Senior Member
    Name
    Cam Douglas
    Member #
    18563
    Join Date
    Jul 2018
    Location
    Tasmania
    Posts
    104
    My Tre-K makes the same "Clack" noise occasionally. I figured it was the cam chain slapping against something, so nothing to be too concerned about.

  9. #8
    Senior Member Rick67's Avatar
    Name
    Rick
    Member #
    16761
    Join Date
    Sep 2017
    Location
    Brynamman ,Wales
    Posts
    426
    Yes same noise happens occasionally on my bike . I'd put the noise down to the engine reversing back slightly at shutdown and maybe moving the sprag clutch a little . Freaks me out lol. Pulling the clutch in on shutdown helps I found
    Last edited by Rick67; 07-15-2019 at 05:52 AM.
    ron d likes this.

Sponsors

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. 250TS kick start tension
    By DaiP in forum Classics
    Replies: 2
    Last Post: 03-20-2017, 02:06 PM
  2. What a kick ass ****ing tune
    By 66shark in forum The Biker Bar
    Replies: 0
    Last Post: 01-23-2011, 01:44 PM
  3. The 'I'm going on a health kick' thread ...
    By Big Bad Al in forum The "Other" Biker Bar
    Replies: 29
    Last Post: 04-23-2009, 10:06 AM
  4. Idle comes down too low, bike shuts down.
    By Distracted Rider in forum TNT
    Replies: 12
    Last Post: 10-14-2008, 01:21 AM
  5. bike down and not starting anymore
    By marcolondon in forum Tornado Tre
    Replies: 10
    Last Post: 12-22-2007, 07:45 PM
Google+