Starts but won't idle
Benelli Motorcycle Forum - Benelli Bike Discussions - Powered by vBulletin
Results 1 to 5 of 5

Thread: Starts but won't idle

  1. #1
    Senior Member Tuono's Avatar
    Member #
    8054
    Join Date
    Oct 2008
    Location
    Toowoomba, Queensland
    Posts
    440

    Starts but won't idle

    Starts but won't idle, cuts out - suggestions?

    Regards

    Tuono

  2. #2
    King of the Group-Buys Laurencewhite's Avatar
    Name
    Laurence White
    Member #
    8
    Join Date
    Dec 2006
    Location
    Edinburgh
    Posts
    7,500
    Stepper motor could be at fault?
    Laurence

    Benelli Tornado 900 LE No. 49
    Benelli 1130 TNT Titainium
    Benelli 1130 TRE-K
    Benelli 750 SEI
    Benelli 250 2c
    Benelli Motorella



  3. #3
    Senior Member Rick67's Avatar
    Name
    Rick
    Member #
    16761
    Join Date
    Sep 2017
    Location
    Brynamman ,Wales
    Posts
    466
    I Agree with Lawrence 🙂 .
    They can be dodgy on little used bikes

  4. Remove Advertisements
    BenelliForum.com
    Advertisements
     

  5. #4
    Junior Member Trotts's Avatar
    Name
    Richard
    Member #
    15225
    Join Date
    Dec 2016
    Location
    Toowoomba, Australia
    Posts
    19
    My R160 was also giving that drama. Solution was to attend to the map but then bypassed the stepper altogether. Ball bearings in the tubes and idle adjusted manually. Takes a bit longer to warm up prior to riding but then no further issues. So far so good.

  6. #5
    Senior Member Tuono's Avatar
    Member #
    8054
    Join Date
    Oct 2008
    Location
    Toowoomba, Queensland
    Posts
    440
    Cleaned the stepper and plugs, all good.
    Many thanks to all for input.

    Regards

    Tuono

Sponsors

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Google+