Benelli Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi guys,

I'm a newbie but am desparate for any info you may have.

My 2004 900 RS Tornado starts, runs for about 3 mins then cuts out. It stops dead ( not runnin on 2 cylinders ) and the Engine management light comes on when this happens.

This started after the bike was laid up in my garage for a short while. Up until then it went fine.

I have checked the crank position sensor & its not that .

Would really appreciate any other tips I could check out first before going to my nearest dealer
 

·
Senior Member
Joined
·
5,929 Posts
My 2004 900 RS Tornado starts, runs for about 3 mins then cuts out. It stops dead ( not runnin on 2 cylinders ) and the Engine management light comes on when this happens.
It could be any number of things, but it sounds a bit like it's lost fuel pressure to the injectors. The ECU would log an error if it detected a problem with the pump.

You need to get an Axione attached, to find out what the ECU is trying to tell you.
Tuneboy would tell you as well.
 

·
Senior Member
Joined
·
1,841 Posts
So when it stops will it start again immediatly? or will it start after a certain time? Will it cut out if you keep revs up slightly? try with fuel cap open (could be blocked vent) Have you got petrol in the tank !!?
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #5 ·
Frustrated

Hey guys sorry bout the delay in responding - work v busy & all that.

The bike will NOT restart immediately. After some time ( tho I've never measured how long ) it will start again.

It seems to be ok after its cooled down completely.

There is plenty of juice in the tank. I will check the tank breather & try starting it with the cap open.

Thanks for the help so far.
 

·
Super Moderator
Joined
·
7,774 Posts
...or it could be that your injectors are bunged up if the bike has been standing unused for a long time.

Oh, and welcome to the Forum too. :clap:
 

·
Fyule
Joined
·
697 Posts
Hi Marsh

Welcome to the forum, if you suspect it is the injectors, I have a set from an RS here, but they too have been sitting for a while, so they may be a bit bunged up too, I'll try some injector cleaner on them over the weekend, if you need them to test things let me know.

cheers
Fraser
 

·
Registered
Joined
·
2,211 Posts
Welcome to the forum Mr Marsh ??

I know next to nowt bout mechanics - I'll leave i to the others to help diagnose your problems.

THis forum is pretty damn good for that :bow:
 

·
Ready for summer
Joined
·
381 Posts
Welcome

to the best forum in the world bar none.As for your woes can.t help not a techie so will leave that to those who know. Hope you get sorted matey :) :)
 

·
Premium Member
Joined
·
4,429 Posts
try revving at a set amount say 3000rpm and see if you get fluctuation in its revs- plus try an additive in the tank that helps fuel injectors be cleaner in operation .good Luck.:)
 

·
Registered
Joined
·
177 Posts
Hi and welcome to the forum fella :clap: sorry to hear your having trouble with your tornado but must agree with my fellow benellians it does sound like a fuel/injector problem,I have had bikes in the past suffering the same symptoms as you describe and it's nearly always been fuel related,make sure your fuel pump is working correctly! if it's a fuel injector problem and the additive doesn,t do the trick it may be wise to have them ultrasonically cleaned then nelly will run good as new.

All the best Kenny.
 
1 - 14 of 14 Posts
Top