Benelli Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
148 Posts
Discussion Starter · #1 ·
Since collecting the TnT on Monday , it's stalled 3 times at lights and in slow traffic, I'm hoping it's down to the stale petrol in the tank?

However, now when the fans kick in, the red light on the dash comes on and the speedo flashes BAT , also my indicators are flashing at double speed.
Any thoughts ?
 

·
Senior Member
Joined
·
5,934 Posts
Since collecting the TnT on Monday , it's stalled 3 times at lights and in slow traffic, I'm hoping it's down to the stale petrol in the tank?

However, now when the fans kick in, the red light on the dash comes on and the speedo flashes BAT , also my indicators are flashing at double speed.
Any thoughts ?
Either your battery needs a good charge, or it's on it's last legs. If it's been sitting around for a few months, with next to no charge, it'll sulfate and it won't be worth crap.

Indicators? Same both sides? If not, it's a blown globe. Unlikely you're that unlucky to have 2 globes gone together.
 

·
Registered
Joined
·
148 Posts
Discussion Starter · #3 ·
Either your battery needs a good charge, or it's on it's last legs. If it's been sitting around for a few months, with next to no charge, it'll sulfate and it won't be worth crap.

Indicators? Same both sides? If not, it's a blown globe. Unlikely you're that unlucky to have 2 globes gone together.
Ah ha, they assured me it's been on the trickle charger since april, hmmmm.
I'll get the optimate out this evening !
Must admit, I haven't checked the bulbs, good call, thanks for the reply.
 

·
Registered
Joined
·
209 Posts
Take it straight back. If it's not right when you pick it up, they should fix it. Who pays will depend on what the problem is, but if the shop claims to have kept it on trickle charge and it's dead, you have to wonde if they did.

ciao
Derek
 

·
Registered
Joined
·
148 Posts
Discussion Starter · #5 ·
Ok. Have put 2 tanks of new petrol through and the jerkiness has reduced, I'll get them to check the tune when I'm up there next week.
2 days on the optimate and the battery light no longer comes on when the fans kick in a low revs.
Still got fast flashing indicators, and all the bulbs are fine ?
 
1 - 5 of 5 Posts
Top