Benelli Forum banner

1 - 7 of 7 Posts
G

·
Discussion Starter · #1 ·
I was wondering what happened with my bikes, showing both -30 Celsius after getting them back from the local shop.

I have researched a bit (service manual is not that helpful in that respect) and found them both missing entirely.

Please confirm if the external temperature sensor is attached to the front frame section (in the service book attached to the right mirror beam under the inner fairing) abd is being plugged directly in the instruments display as I hava a two pole connector out of the instruments display that is hanging free.
 
G

·
Discussion Starter · #2 ·
Bad Service

Make those idiots do their jobs correctly mate. If you paid for it, you deserve at least that.
 
G

·
Discussion Starter · #3 ·
Re: Bad Service

Situation was reported to Benelli factory and they promised to push for correcting things.

I am not in my 20's anymore, therefore I am not holding my breath on their word.

Also consider to take legal action but that won't bring my bikes sooner on the road.
 
G

·
Discussion Starter · #4 ·
Re: Bad Service

Hi Aquilla,

The sensor for the Air temperature gauge is usually bunched up with the cable and held onto the inner fairing frame with a rubber strap.

The two pole connector for this is indeed at the rear of the clocks but there should also be another of these which is used for the LED indicator if you have the Gemel alarm fitted.
 
G

·
Discussion Starter · #5 ·
Re: Bad Service

Hi, any idea where to buy the part from, independent from the truly amazing Benelli network here at my reach?
 
G

·
Discussion Starter · #6 ·
Help maybe?

Hi Aquilla,
I have been here before. One of our bike's dash clusters read in negative temp, there is a connector on the right hand side near the the handle grip, it is a two wire lead from the dash to a connector, from there its an extension wire that has a probe at the end tied to the frame near the fuel tank. If the wires on both connectors are all black, it's wrong, one should be black and red and the other black and black. Sorry, it sounds a bit confusing but when you look at the connector it makes sense. It can only be hooked up two ways and I bet its been done the wrong way...
Hope this helps, Dave
 
G

·
Discussion Starter · #7 ·
Well, someone made things simpler for me. There is nothing attached to the connector that exits the dash. It is hanging free on both bikes.

Thanks for confirming that these are the wires as I supposed.
 
1 - 7 of 7 Posts
Top