Benelli Forum banner
61 - 74 of 74 Posts

·
Registered
Joined
·
91 Posts
Has someone tested this soft with Tornado Tre 1130? I'm having some issues with TuneECU... I just cant clear error codes.
 

·
Registered
Joined
·
91 Posts
I can confirm it works on a Tornado Tre 1130 with a Athena ECU A1 (A1BEN02).

Just connect, Clear Diagnostics and the K ligth is off :)
 

·
Registered
Joined
·
174 Posts
No connection on TreK with ECUA1

I can confirm it works on a Tornado Tre 1130 with a Athena ECU A1 (A1BEN02).

Just connect, Clear Diagnostics and the K ligth is off :)
Alieb you have given me a glimmer of hope that this might help the owner of a 2014 TreK with an Athena ECUA4 that is not supported by TuneECU. I tried the program on my 2013 TreK with ECUA1. So far I have only achieved an error message. I am running Windows 10 and have tried both FTDI and Prolific USB to RS232 cables on COM1. (Both of these cables work with TuneECU.) I tried using Windows XP running on VMWare. It has been the same result every time. The port settings are the same as Roberto used. What equipment did you use? Can you offer any tips that might help me get connected? Thanks, Rolf
Rectangle Font Screenshot Parallel Software
 

·
Registered
Joined
·
91 Posts
Alieb you have given me a glimmer of hope that this might help the owner of a 2014 TreK with an Athena ECUA4 that is not supported by TuneECU. I tried the program on my 2013 TreK with ECUA1. So far I have only achieved an error message. I am running Windows 10 and have tried both FTDI and Prolific USB to RS232 cables on COM1. (Both of these cables work with TuneECU.) I tried using Windows XP running on VMWare. It has been the same result every time. The port settings are the same as Roberto used. What equipment did you use? Can you offer any tips that might help me get connected? Thanks, Rolf
I have bad news, 1st, TuneECU works 90%, all the time but the error code thing... I can read maps, write maps, reset TPS, set CO values, and reall 100% fo the sensors.
So I knew the cable was rigth from the beginning.
then just started benelli service, and did a Clear Diagnostics and thats all (the other 10% of TuneECU can not do)... so TuneECU + Benelli Service = 100% of what I need.
I did not check any other functionality of Benelli Service that TuneCU has...

I m using
1) Windows 10 Pro in a Lenovo T460S, I run the software in native mode, not in VMWare, virtualization is error prone for real time systems (dont ask me why I know that, Leib ICT S.A. - Software for Mobile Operators, System Integrators, MVNOs - Sigtran, USSD, SMS, CAMEL, CAP, TCAP, MAP)
2) Use Lonetec cable Kit for WALBRO cables (Athena ECU is Walbro compatible)
3) nothing more

I configured the cable as COM1 (defaulted to COM4)
 

·
Registered
Joined
·
174 Posts
TreK diagnostics worked

Thanks for replying Aleib, I seem to have the same result as you. The diagnostics apparently work but not the console. It detected a disconnected TPS. Unfortunately for the owner with ECUA4 I found no way to check or reset the TPS on my bike with this program.
 

·
Registered
Joined
·
91 Posts
Thanks for replying Aleib, I seem to have the same result as you. The diagnostics apparently work but not the console. It detected a disconnected TPS. Unfortunately for the owner with ECUA4 I found no way to check or reset the TPS on my bike with this program.
Did you contact Alain, maybe he can help, its the real expert in ECU here...

I'm not sure why there are differences between ECUA101 02 and 04 (probably there is a 03 too :)
 

·
Registered
Joined
·
174 Posts
Alain has not responded to my support query. I guess he is inundated with queries and this one is way down the priority list since there are only a few bikes concerned.
 
61 - 74 of 74 Posts
Top