Benelli Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hey everyone new owner of a tnt 135 love the bike especially coming up a Vader/Boom (grom knock off). So I have a little over 600 miles on the bike and I recently started having issues. I’d be out riding and all of a sudden my check engine like would pop on and kill the bike. From what I’ve read and researched people said it could be either an issue with the 02 sensor, ECU, or fuel pump. The bike is still under warranty and am taking it to a dealership to get looked at. Anyone else here have similar issues?

The bike starts up fine when it’s been sitting and will ride fine but after a few minutes or so the engine light comes on and dies. Anyways thanks in advance for any help or input.
 

·
Registered
Joined
·
13 Posts
hope youve since sorted it.

im at 2500 miles of HARD track and mountain use.

only here now because its completely dead, and it seems i have the most experience on it rouun these parts -.-
 

·
Registered
Joined
·
652 Posts
I had a look online and couldn’t find a wiring diagram. Is anything working? Lights etc. I don’t know about this bike but try the usual things clutch switch, side stand switch, fuses, relays .A multimeter is very useful tool if you can get one.
 

·
Registered
Joined
·
13 Posts
Yeap everything dead. Wish I had meter but I'm visiting my folks who don't have one. I don't think it's batt because even with the jump pack on there is NO life.
 

·
Registered
Joined
·
182 Posts
i thought i was losing my mind. ive nearly torn the whole ^@%!# bike apart even fuel tank and cant find that fuse. that manual is for a 1130 not 135. :doh:

took leads off batt and connected directly to jump pack, still no life. it must be some idiotic connection. arrrgh

Sorry, my bad :doh:
 
1 - 11 of 11 Posts
Top