Benelli Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hi, just replaced dead battery after bike standing for approx 3months, bike now cranks over but when the key is turned on the fuel system is not firing up, what could be the issue?

Tia
 

·
Registered
Joined
·
30 Posts
Hi, just replaced dead battery after bike standing for approx 3months, bike now cranks over but when the key is turned on the fuel system is not firing up, what could be the issue?

Tia
Check fuse & relay. After that check are fuel pump working, make sound in fuel tank after key on. There are a case that rotax fuel pump sluggish with bad fuel after long sleep, good luck

Sent from my Zenfone Max Pro M1 using Tapatalk
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
check fuse & relay. After that check are fuel pump working, make sound in fuel tank after key on. There are a case that rotax fuel pump sluggish with bad fuel after long sleep, good luck

sent from my zenfone max pro m1 using tapatalk
i think i have checked all fuses and relay but still no sound, pump not priming. Do you have a picture of where the relay and fuse would be to confirm i have checked the right ones.
Thanks
 

·
Registered
Joined
·
1,297 Posts
Hi just another thought .. the connections in the fuse box may need some electrical contact cleaner also .. this may help a with bad connection or a sticking relay .
You could also disconnect the fuel pump and wire it to a 12volt supply direct to check it runs ..
Seems odd after only changing to a new battery from standing a while 🤔
 
1 - 5 of 5 Posts
Top