Benelli Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
290 Posts
Discussion Starter · #1 ·
My nelli had to go back to the importer yesterday:bawl: There they have a full Benelli techy.

The bike decided it didn't like running on all three pots developed a really bad missfire. Accelerated great but wouldn't cruise at any speed and was a bitch accelerating from light, cut out (Stalled) nearly spat me and my son off:mad:

They told me that the bike had likely taken a dislike to the mapping and that they had had this happen a couple of times bfeore. It has caused the plugs to oil up.

The importer told that Benneli have produced 11 remaps some have worked some havn't. Mine has the latest mapping and they think that it is causing the problem.

It (she) now requires new plugs and remap. all under waranty. the bikes done 1400 miles.

3rd time in the workshop since new 1st time was at 700 mile for 1st service.

Getting the opinion that everytime I go out on the bike I need to take back to the dealer to fixed :mad:
 

·
Bristol Member
Joined
·
102 Posts
My nelli had to go back to the importer yesterday:bawl: There they have a full Benelli techy.

The importer told that Benneli have produced 11 remaps some have worked some havn't. Mine has the latest mapping and they think that it is causing the problem.

:
Hi Glenn, I had the latest maps installed on mine at 1200miles about 3 months ago and in town traffic it ran like a pig continuous clutch slipping required. It wouldnt idle nicely and it neaded a handfull of revs to clear itself to pull away from the lights.
I took it back to my dealer and they put the previous maps back on and spent about an hour messing with the co2 settings. The result is fantastic and I could tell before I pulled away from the dealers forcourt, there is no noticible reduction in performance but now it will trickle along in traffic in 1st gear without needing to slip the clutch.

Good luck with yours.

I'm wondering if a power commander with a custom map would improve things much!
 

·
mid life crisis merchant
Joined
·
897 Posts
Hi Glenn, sorry to hear nelli's not well :( but glad to hear you and your son are ok :clap:
Ive been experiancing a bit of trouble with my old girl having a flat spot/blip when you cane her, and thought it may be the mapping:confused:

took my lad on the back for the first time ever when there was a break in the weather ( and when i wasn't in work!) on sat night, mind you I'd never give it bags full with him on but she never coughed once and he loved it ( he said I was a legend :) )

But hearing your problem I think I might leave it again until I've sorted her out properly.
good to hear your both ok though :D

hope you get her sorted soon mate

Johnny :cool:
 

·
Registered
Joined
·
290 Posts
Discussion Starter · #4 ·
Think I will give the dealer a call and ask them to put it to the previous map. and check the Co2. They can only say no:(
 

·
Registered
Joined
·
290 Posts
Discussion Starter · #5 ·
Its back turns out that the Clutch switch had a fault and needed replacing. Dealer also fitted new plugs. :ele: :ele:
 

·
Registered
Joined
·
45 Posts
Glad to hear all is well now, one thing to watch out for (as this happened to me in spain) my bike was not starting everytime. I traced it to the rubber boot on the clutch lever which had drifted away and pulled the 2 wires on the switch which is a cut out ive siliconed the boot on now.

Wosser
 
1 - 7 of 7 Posts
Top