Benelli Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hi all, am new the the forum.

Was looking for some help on various bits and bobs,(only had the bike since november-so it's all a bit new to me) one is locating a chain and sprocket set for my Tornado-2003. Gernally not having much luck on finding a set anywhere, the bikes only got 3800miles on the clock but chain's streched/rusty :( and would like to replace it with some gold bling??

Some other points are, the outside temp indicator reads 21 all the time??,Temp gague sometime's reads in the red,but no fault message appears,pull over turn it off,on a couple off times and she reads normall temp?? When pulling up to a junction,she'll cut out sometime-i can start it straight away and no problem??

Any help would be greatly appricatied.
 

·
Registered
Joined
·
736 Posts
Welcome,
It`s like life on this forum........we loose one (BenGreen) and gain another to the fold:) :)
I have spoken to a few companies about chains and sprockets and I know that B & C Express will supply them.
Also spoke to a guy called Jay at Stealth Products who has made some ultra sexy disks for me. Pics soon in my album.
Anyway he said he can make sprockets if he has 1 to copy. May be you could speak to him. http://www.stealthproducts.co.uk/products/sprocket.php
Cant help with the dash probs but someone will.
Anyhow ENJOY the Benelli, we know you will and you will find all the guys and gals on here real helpful.
Dave
 

·
Super Moderator
Joined
·
7,770 Posts
Hi Dazza and Welcome,

The clocks on the early bikes seemed to be more problematic than the later versions. There was a recent post on this that provided some more info.

http://www.benelliforum.com/forum/showthread.php?t=1673

The cutting out as you approach junction also seems to be quite common. It's been reported that if you get your dealer to increase the idle speed up a bit to 1500 revs this should help to reduce it happening so frequently.

May all your problems be small ones ;)
 

·
Senior Member
Joined
·
5,899 Posts
Welcome to our forum Dazza.

On the cutting out problem - not shifting into neutral until the revs drop to 2500 seems to help. The theory is that it gives the ECU more time to correct the mixture.

My idle has been increased to 1500 and the problem has nearly disappeared.

A combination of both should solve it.
 

·
Registered
Joined
·
53 Posts
Welcome to our forum Dazza.

On the cutting out problem - not shifting into neutral until the revs drop to 2500 seems to help. The theory is that it gives the ECU more time to correct the mixture.

My idle has been increased to 1500 and the problem has nearly disappeared.

A combination of both should solve it.
That is the combo that curried mine. The higher idle helps alot but the holding out on pulling in the clutch until under 2,800 was the final icing.
 

·
Unofficial Factory Tester
Joined
·
166 Posts
DID have a 525 Chain

Hi,

DID have a 525 Chain for it. Not sure what the model was though, about 114 links, if memory serves. This is what I have on at the moment, outer links are in gold/bronze.

Just go to a dealer and they should be able to help you.

cheers
 
1 - 6 of 6 Posts
Top