Benelli Forum banner

1 - 6 of 6 Posts
G

·
Discussion Starter · #1 ·
I looked under my tank today and I found there are no clips
on each end of the fuel pipe !, the pipe is just push fit !
I looked in the manual and it does not show clips.
the pump pressurises to 3.5 bar (51 p.s.i.) and i am surprised at this so I will be buying a couple of clips !!!!
Has any one got clips on theirs ?:rolleyes
 
G

·
Discussion Starter · #2 ·
Mine doesn't have any, and it doesn't need them. The pipe is stong as. It was quite a struggle to fit a quick-release fuel connector. The only way to remove the pipe from it's fitting is to cut it off.

There's a picture of the cut pipe here.
See how much it has expanded over the original fitting? It's not falling off in a hurry.
 
G

·
Discussion Starter · #3 ·
Thanks Engenia, I suppose the hose may possibly be bonded to the fittings ?, the quick release connector looks like a good idea and takes away the risk of breaking the hose pump connection. another job on my list....:rolleyes
 
G

·
Discussion Starter · #4 ·
Mine neither....The fuel pipe was attatched the to the plastic thingy at the bottom of the tank so well I couldn't get it off....

even with loats of swearing!!!

Quick release coupling.....see Enginas web bit
 
G

·
Discussion Starter · #5 ·
My bet is that the original fittings have barbs, just like the quick release, but even bigger.
Laurence has fitted the quick release as well. He seemed pretty happy with it. I'm sure you will be too.
 
G

·
Discussion Starter · #6 ·
"He seemed pretty happy with it"

Yeah, I'll second that.

If anyone wants to do the mod. just follow the instructions on Enginia's web page and you can't go far wrong.

Cheers,

Laurence
 
1 - 6 of 6 Posts
Top