Benelli Forum banner
1 - 7 of 7 Posts
G

·
Discussion Starter · #1 ·
when riding my bike i have found that if the throttle is shut at any revs above 2800 the engine does not fire at all until it slows to 2800, if the throttle is opened on the overrun at over 2800 it cuts in. if you are at about 5000 or higher it is smooth enough, but if you are in traffic at 3000 to 4000 every time you shut off it comes back in with a surge .
this is a bit irritating especially when turning.
I think this may be able to adj at service and i think it is to do with the stepper thingy.
does any one have the same situation? or did and rectified?
or are they just like this and i`ll have to live with it...
also has any one fitted a better throttle? its a bit slack.
any comments appreciated.:rolleyes :rolleyes :rolleyes
 
G

·
Discussion Starter · #2 ·
Colin,
picked up my RS on Tuesday,,

My throttle is also on the slack side...I get an awful resonance/vibration/flat spot at 3500 to 4500 revs.

Just like your, mine clears it's throat and sods off like a good 'un at 5000 revs.

Be interested to know what the problem is...I suspect throttle body synch.

Dave
 
G

·
Discussion Starter · #3 ·
I posted a query about the resonance/vibration issue between 3500 & 4000 rpm on the 18th July. The interesting thing about mine was it did not really manifest itself until the ecu was changed from 6020 to 6033 and the clutch basket was replaced when the bike had done about 3500kms.
Prior to that it was not really noticeable - now it cuts in with quite a vengeance. Nice to know I am not the only one who has noticed it. But how to remove it - therein lies the 'rub'???
Cheers,
Vince
 
G

·
Discussion Starter · #4 ·
rough spot

I'm keen to have mines looked at by either Mtune or some dyno operators in Perth to suss this out Vince, I'll most likely wait until the UK guys suss theirs and see if its fuelling or throttle sync,
 
G

·
Discussion Starter · #5 ·
vibration

Hmmmm? Don't what it could be. I think the bikes vibrate a bit anyway (120 degree triple).
 
G

·
Discussion Starter · #6 ·
Re: rough spot

hi dave , i hope you are enjoying your bike! this resonance thing is just like mine,but i have found if i keep on light throttle its ok, it seems that it has good torque at 3500 to 4500 but if too much throttle is givern at these revs it does not feel like is doing the engine much good ! (vibration).
when i tested a tre (not rs) it did the same, only at a bit lower revs,then smooth after. this is probably just the way the engine is.
when i adjusted the cables it is easier to be more precise on throttle but they are a loose fit on the bars ! i will look to find a better type.
 
1 - 7 of 7 Posts
Top