Benelli Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
251 Posts
Discussion Starter · #1 ·
I got my cafe racer new a few months ago and on standard fueling i was getting a bit over 100 miles per tank. Then after its first service i started getting 40 to a tank. I took it in cos it was clearly running rich, they sorted it and once more i was getting 100+ to a tank. :D

A month a half down the road and i appear to be getting 60(ish) to a tank. I need to check this and pay more attention to my trip but i reckon its about right.:doh:

What is going on, is it adjusting itself? How can this be?
 

·
Registered
Joined
·
736 Posts
Or is it that you cant control yourself with the throttle, like all of us TNT owners :rolling: :rolling:
I get about 70-80 miles per tank, and people used to moan about the SP1`s doing about the same!!!!
 

·
Registered
Joined
·
1,082 Posts
I heard of them, these italian gremlins sitting in your tank and having "Teatime" all day long.... :rolling: :rolling:

....and sometimes when it´s very hot outside they invite friends and than they you can be happy if you make 40miles. There is one way to get these gremlins under control: The Powercommander he is strong enough to get them under control :rolling:

:ele: :ele: :ele:

Jokemode out.

here a little overview from german fuelgremlins :D

Blue: average fuel consumption each machine at 100km
yellow: average fuel consumption each MODEL at 100km

 

·
Registered
Joined
·
251 Posts
Discussion Starter · #5 ·
Its not from being handy on the throttle at all.Its just been easy going town riding.

I am concerned that this change in the fueling might be part of an underlying problem. No idea what though. This is the second time though that it has randomly taken it upon itself to run rich:doh:
 

·
Registered
Joined
·
1,007 Posts
I presume the CR has the fuel map button? Are both of the maps now running rich? Might help identify whether there is a physical change in the bike or a scr*wed up map
 

·
Registered
Joined
·
346 Posts
I got my cafe racer new a few months ago and on standard fueling i was getting a bit over 100 miles per tank. Then after its first service i started getting 40 to a tank. I took it in cos it was clearly running rich, they sorted it and once more i was getting 100+ to a tank. :D

A month a half down the road and i appear to be getting 60(ish) to a tank. I need to check this and pay more attention to my trip but i reckon its about right.:doh:

What is going on, is it adjusting itself? How can this be?
Motty AFR tuner is the only good solution in my opinion.. :(..
Unfortunate that you have to spend 500 Euro or so to correct a factory defect....
My bike would do the same thing..
The cause is probably that they can't stop the bike from running too rich.. PERIOD..
They just can't do it for whatever the reason..
I think this is causing your plugs to foul out a little..
Each time they remap it they're probably adjusting based on the amount of spark you're getting and while doing this the carbon deposits are probably cleaning up slowly.. Eventually you have clean plugs and a new tune.. You get your bike back, ride it, foul the plugs out, and start all over again..
Change to the Iridium plugs and see if that helps a little.. I am sure, at first, you'll notice a HUGE difference.. Then tank #2 or 3 you'll be getting bad fuel consumption again..
 
1 - 7 of 7 Posts
Top