Benelli Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
I tried starting the bike this evening and when i turned the key i had no power to the display. The lights, indicators and horn all work. The battery is fully charged. This is the first time i have had any sort of problem, does this sound familiar to anyone?

I have read some threads on here and plan to disconnect the battery to reset the clocks in the morning. I also understand that there is a "starter fuse" - although im not sure if this is relevent.

Any further help would be magnificent!

T100 RON (new private plate)
 

·
Senior Member
Joined
·
903 Posts
Flat battery!

:p

:hiya: Ironica, do you have an alarm on your steed, if so this can drain the battery quite quickly unless you have a battery optimiser (trickle charger.).

I also used to press the ignition kill button in to disconnect the current when the bike was not being used as other more technical members of this forum said that it is a cause of some current drain.

Hope this helps
 

·
Senior Member
Joined
·
5,963 Posts
I tried starting the bike this evening and when i turned the key i had no power to the display. The lights, indicators and horn all work. The battery is fully charged. This is the first time i have had any sort of problem, does this sound familiar to anyone?
Is the gearbox in neutral? If not, it will do exactly as you have described, and not start either.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #4 ·
many thanks.......

.............im glad it was something simple!

i didnt realise it was in gear... grrrrrrrrrrrrrrrrr

T100
 

·
Registered
Joined
·
189 Posts
I recently had also a problem with the electronics of my Tre. In my case the engine won't start either and the display on the dash says "Inglaise Unitad". This occurs after a ride of 50 miles at a gasstation so the battery must be fully charged. The solution is quit simple:
Remove the 30 amp fuse at the left side of the bike. (I think that is also the reason why that fuse is so reachable), count to ten. Put the fuse back in and voila............running.:D
 

·
Registered
Joined
·
2,211 Posts
.............im glad it was something simple!

i didnt realise it was in gear... grrrrrrrrrrrrrrrrr

T100
Had to smile to myself - I thought I was the only plum to have done that ! :doh:

I even called my mate out with a van to get me back home once too !!!!!!!!! :doh:
:rolling: :rolling: :rolling: :rolling: :rolling: :rolling:
 

·
Senior Member
Joined
·
5,963 Posts
I think we've all done it. It happened to me within a week or 2 of getting it. It was dark, and I was about to get a very long walk.:doh:
 

·
Registered
Joined
·
2,211 Posts
Phew ! :doh:

Thought it was only the 'special' few who actually dont realise and start making plans how the hell to get you and the bike home !!! :D :D
 

·
Senior Member
Joined
·
903 Posts
Dim?

And there was me thinking you where a bright bloke kurt!:doh: :rolling: :rolling: :rolling:

I rode into a petrol station once and spotted a particually pretty young woman getting out of her Mazda MX5. To show off whilst she was looking at me I flicked the side stand down and got off my bike in one quick movement only to find the bike fall over as the stand had not locked.

Did I feel a prat? You bet I did!:rolling: :rolling: :rolling:

We've all been there!
 

·
Registered
Joined
·
2,211 Posts
Lloyd - I think you will find that we all have not been there - well not as far out as your cool dismount from your bike anyway ! :rolling: :rolling: :rolling:

When are you actually gonna get your grubby mitts on your MV then?
Need to know and need to meet up one weekend when your on a rideout with the Italian Bi-atch ! ;)
 
1 - 11 of 11 Posts
Top