Benelli Forum banner

21 - 40 of 45 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter · #21 ·
Morning again took tank up and turned it around,took air box off,all wires look fine unplugged them and sprayed with wd40 then plugged in and out a few times.still nothing but I did notice when I turn engine over lights come on but go out once engine fires up.still baffled lol
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #22 ·
I can switch between main and dipped with engine cranking,but soon as fires up lights go out except side light.took switch apart that looks ok too
 

·
Registered
Joined
·
1,100 Posts
I can switch between main and dipped with engine cranking,but soon as fires up lights go out except side light.took switch apart that looks ok too
That's like the complete opposite of what it should be ... Isn't it ? .
I've not seen how the tre 900 lights work but on my Trek it's that way round.

It's almost as if a relay somewhere is working the wrong way round ..
 

·
Registered
Joined
·
909 Posts
I am thinking the plug from the switch is the problem anybody selling a switch? Please please

I have got the entire switch gear off that handlebar, but i do not think it is at fault.
You can test all wiring with a multi meter , each pin in the plug gives you a coloured wire, you can trace that back into the clamp grip
and test you have no breaks in the wires.
The bikes with that switch gear, Tornado Tre 900 do not require the bike running to work. simply ignition on and the lights work. Side light , then headlight(beam or Dip)
with lights off, the headlight flash works , and also works over the sidelight and dip beam being on..
The lights remain on even if you crank the bike and continue to be on when the bike fires and is running.
That the lights work when you are cranking the bike is your problem, that they do not with the engine running reinforces that .
 

·
Registered
Joined
·
909 Posts
I am thinking the plug from the switch is the problem anybody selling a switch? Please please

If you are determined to pursue the switch gear replacement , it is a standard Euro switch, readily available from Domino Tommaselli.
They are on Ebay at about 50 Eu, but that seems a bit pricy just to find out , it is not the switch.
Both Aprilia and Ducati used the switch during the 90,s but a secondhand one might be no better than the one you have.
I know the RSV used the non light switch version.
 

·
Registered
Joined
·
909 Posts
I give up tested the wires on switch ,tested the wires going to fuse box all seem fine

Thats £50 odd saved then, if all the wires are good then a new switch gear and plugs is not going to sort it.
Did you identify which pin/ colour cable provide the positive feed to the switch itself ?
if you take a feed from the battery to that wire, the lights function should work. Ignore the ignition switch , and /or cranking it. or even have the engine running .
if the lights work on all functions then , it has to be a positive feed from the ignition switch that is not providing 12v.
see if you can get the lights to work first.
 

·
Registered
Joined
·
1,100 Posts
Just a thought ... If you get lights to work whilst cranking check the positive feed is on the correct side of the starter relay
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #34 ·
Hi mate just been looking at starter relay and wonder if the insides of it have gone wrong somehow with how my lights switch on as I crank engine and switch off when engine fires up?
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #38 ·
Ordered it should be here friday or Saturday will let you know if it sorts it thanks alot mate really appreciate your help
 
21 - 40 of 45 Posts
Top