Benelli Forum banner
1 - 11 of 11 Posts
G

·
Discussion Starter · #1 ·
Today I took the Tre out for a little spin as I want to get as many miles under my belt before the really crappy weather sets in. Anyway, I get her out the garage and fire her up. Hmmmm, sounds a bit off and she starts to idle to the point were you think it's just going to stall. I think nothing of it and hop aboard. Then I give her a little more gas to get us both going and I realise that she is starting to sound more like a Harley fatboy than the sexy Italian number she's meant to be. Sitting at tha junction I have to keep the revs up to stop it stalling on me and when I go to pull away there seems to be very little power on tap, just the 'chug chug chug' of the engine. A little more gas and she bursts into life and we shoot off but it still left me with a little niggling doubt that something is going to go wrong. Then I noticed that when I'm braking quite hard from a fairly decent speed I can hear what sounds like a backfire. This happened on more than a couple of occasions and made my ride out a worrying one rather than enjoyable. Then to top it all off the clutch seems really snappy in my hands but seeing as I haven't been on the bike for so long then it may just have always been like that, but somehow I doubt it:(

I guess I'll be calling KJM tomorrow when I get back from work (again):(

Al|I
 
G

·
Discussion Starter · #2 ·
Al, your not having much luck mate,:( it sounds like a plug or stick coil is giving up, I had a coil pack up on the TNT last month ran just like you described......... if it is they could fix it while you wait so its not off the road again:D ................ your truly one patient scotty:lol :lol
 
G

·
Discussion Starter · #3 ·
Hey Al,

I get a popping / farting noise when blipping the throttle on downshift occasionally..

Could it be the same sympton?

Stu
 
G

·
Discussion Starter · #4 ·
I had a coil pack up on the TNT last month ran just like you described......... if it is they could fix it while you wait so its not off the road again
Jeez I hope your right vtxbrit:eek: I think I may just snap if it turns out to be something more serious>: ;)

Al

Stu, what does it feel like when you give her a bit of throttle from a standstill? Does she pull away smoothly enough?
8o
 
G

·
Discussion Starter · #5 ·
Al, mate you got some patients! VTXBrit has got it spot on, for some reason sometimes after a service (Although I dont think your bikes had one yet!) the 2nd cylinder plug/coil goes. I spoke to a mechanic for benelli. They havn't a real reason why but its not a long job if your get the right guy to it. You get an almost twin sound (harley) and yeah it'll run like a bag of sh*t inc the stalling etc. As for the clutch that sounds a little odd 'cos there not grabby I dont think, I dunno maybe the oil?

Mines still waiting on the replacement gasket to seal the gearbox casing. All the bits have been replaced and strengthened so she should be 100% now. Also got a replacement peg coming down. Only thing I havnt replaced is the mirror. It'll be ok but its a little poorly looking. Hey not been on the road since Isle of Man I could be catching up on how long you had to wait Al :b

Dean
 
G

·
Discussion Starter · #6 ·
Guys - you really are filling me with confidence. Here's me, two years after an off (that broke bones), wanting another bike (ideally a Benelli) and i read nothing but problems. Is it still worth thinking about the Benelli ?? Or am I reading too much into this - YOU are the people in the know and I know you mean well - Help !! <img border=0 src="http://www.ezboard.com/images/emoticons/eyes.gif" />
 
G

·
Discussion Starter · #7 ·
missing

It could be an ignition coil, I have two bikes fail them here but most common is a blocked injector; one of my demo bikes started doing it when I was on a ride; I gave it a couple of full throttle/max rpm bursts; it must have suck the @#%$ through coz it has run perfect ever since.
 
G

·
Discussion Starter · #8 ·
Hi spud, in answer to your question……. you have to appreciate that these types of forums are mainly about problems and the experience of the members in getting over them I have had quite a few bikes over the years and have (and still am) a member on many forums..... trust me every bike model has problems :rolleyes with forum members pulling there hair out, yes there are some significant problems with the benelli which are fixable but the basic design in my opinion is superb :D the experiences and banter of motorcycle forums is very important but remember it is concentrated discussions and anything concentrated takes a bit to swallow (oh except a good scotch wouldn’t you say mr BIG BAD AL) :rollin
 
G

·
Discussion Starter · #9 ·
Is it still worth thinking about the Benelli ?? Or am I reading too much into this
Take it all with a pinch of salt Spud;) Sure, my bike has had more than it's fair share of problems but I try to not let these things get to me. Vtxbrit has kinda nailed the problem on the head by saying that every bike has it's problems. I spoke to Brian at KJM today and he's told me not to worry about the problem as it'll get fixed when I go down to get my wheels fitted. (Just needs Glen to whack it with a spanner and we're laughing:lol )

Right, enough of this typing malarky .... time to get the power rangers suit on and get out there and play
:smokin

Al8)

Quick update:

Johnny O, I gave the bike a right good blast today and it seems (fingers crossed) to have cured the problem. It did cut out twice on me, quite unexpectedly, so I'll get KJM to have a wee sniff about when I'm down there next.

Al:D
 
G

·
Discussion Starter · #10 ·
stalling

I just had the same problem with revs dropping, stalling. Took it in to the dealer and they downloaded the latest 2006 ECU or summit. Certainly runs better and BOY is it quicker too! (I have a 2003 TRE.) Not sure if it's fixed the problem as I've only done 50 miles since - most of the time it seems ok but a couple of times it has seemed like it would stall and I had to give it a few revs and it was then ok. If it continues, the info on this forum will be a great help. Thanks guys.
 
G

·
Discussion Starter · #11 ·
Re: stalling

Mine hasn't had the stall problem at all (touch wood)

Now got 1650 miles on the clock on the RS

However since day 1 after using id to high revs for a while and then throttling off at about 4K I nearly always get a overrun bang.

doesn't seem to upset it so I'm presuming that this is all to do with the mapping/emmisions thing...especially as throttling on there is that flat spot between 3K and 4K ish. I am just presuming they're linked.
 
1 - 11 of 11 Posts
Top