Benelli Forum banner
1 - 19 of 19 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter · #1 ·
Hi , ive come to the Fact i need to remap the tre k , as not only does it smell like its running rich it also empty the tank rather quickly , the bike has only done 900 odd miles from new so should i leave it bit longer get some miles on the clocks see if it settles down or get it done ? also any ideas where an what app to use ?
 

·
Registered
Joined
·
201 Posts
Hi , ive come to the Fact i need to remap the tre k , as not only does it smell like its running rich it also empty the tank rather quickly , the bike has only done 900 odd miles from new so should i leave it bit longer get some miles on the clocks see if it settles down or get it done ? also any ideas where an what app to use ?
It will more likely to be the TPS that needs resetting. Make sure you do this before remapping. Nigel.
 

·
Registered
Joined
·
31 Posts
Discussion Starter · #8 ·
At last finally got round to getting the bile remapped , My friend Teddy who use to race at the TT done , set it to its leanest setting . id describe it first ride as like its been Tammed much calmer to ride thats my impression first of , Second time out its very similar , very smooth an goes like shit when you want it to fuel wise well il update soon a is get a idea what its doing to the old Gal, but first impressions are positive .
 

·
Registered
Joined
·
199 Posts
Since I replaced a dodgy TPS and tweaked my map in 2018, my 2013 TreK has averaged about 6L/100km, riding at legal speeds in Australia. I recently realised the O2 sensor had failed. That explains why it was using a bit more fuel for a while. A replacement sensor seems to have improved things for the last couple of tanks. My records are here Tre K (Benelli TRE K 1130 ) | Fuelly
 

·
Registered
Joined
·
31 Posts
Discussion Starter · #16 ·
Ok went out on the tre k yesterday , gave it a good run incidentally the rear mudguard an tail piece was flying about quit a lot according to my mate specially over 100 mph , perhaps il have to get shot of the mudguard , got a GPR exhaust fitted an done right but got this prob ? have to remount the number plate too i would imagine , anyway bike goes alright say its ok up to 130mph then starts to get a bit light on front end , first part of trip was slow ride 50-60 then last 40 miles was a blast , average at 34miles per gallon an no doubt if was going more careful can reach 40 plus per gallon , dont know how this stands up with anyone else part from redbarron cheers for that dude !
 

·
Registered
Joined
·
31 Posts
Discussion Starter · #17 ·
Done load of miles on the bike now an fuel is so much better , getting a good 35 t 40 to the gallon , ben ranting it around like you do still pretty good so very happy with the remap !
 
1 - 19 of 19 Posts
Top