Benelli Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
the service indicator is on when i start the bike up is there a way of stopping this have changed oil/filter had small service done before going to scotland bike has know done 3600miles
 

·
Senior Member
Joined
·
1,841 Posts
service light

Press mode button, switch on ignition, wait for service to go out, turn off ignition.(thats what is in my little note book anyway !)
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #3 ·
service light

thanks colin tried this and nowt seems to be happening i cant get lap timer up anything all it does is set the trip back to zero ive tried loads of times is there any other way to clear the service sign off the clocks or is it a trip back to the dealers
 

·
Premium Member
Joined
·
828 Posts
There is a way, as I did it, I just need to remember how to do it.

It is something to do with having the ignition on, then in one of the modes, holding the 'select display' button in for ten seconds then the spanner disappears. I just can't remember which mode you have to be in to do it!:doh:

Andy
 

·
Senior Member
Joined
·
1,841 Posts
reset

Hi Prince, Are you in total mileage/trip mode ? If you are it should work.
The mode buttons are horrible and you may be getting poor contact. I find it impossible to use if moving !
When you hold it in you may have to wait a bit of time before it works.
If you hold the button in for over two seconds you should go into chrono/lap mode. If none of this is happening you could try dissconecting the battery for a few seconds as this may reset the clock electronics then try again.
Good Luck !!!
 
1 - 6 of 6 Posts
Top