Benelli Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
997 Posts
Sounds like maybe z25 gear/shaft. if you remove the alternator and check that the shaft cannot be turned too easily, or remove clutch cover and check at that end. Or it could be a sprag clutch issue but I wouldn’t have thought there would be any noise.
 

·
Registered
Joined
·
997 Posts
If the gear on the rear of the clutch has survived and you can retrieve the parts it will just be the z25 shaft and gear plus locking bolt and Belleville washer that needs replaced.
 

·
Registered
Joined
·
997 Posts
The gear I meant is the one fixed to the clutch basket. But you will have to remove the clutch anyway to fit the new z25. As the shaft and gear are normally fitted as a pair.
 

·
Registered
Joined
·
997 Posts
Don’t think the new type m10 bolt with Belleville washer normally shears they can come loose though.The main problem is the shaft shears as yours has, the shaft is under heavy load during start up.
 

·
Registered
Joined
·
997 Posts
As Rick says I tend to use loctite on nearly everything hardly ever causes any problems and I have copious amounts of the stuff in different versions.
 

·
Registered
Joined
·
997 Posts
Was the noise there during cranking, running or both and clutch in or out? when you put the z25 shaft bits together does it look complete? Probably easiest to pull clutch cover off and see if there is any obvious wrong in there. The neutral light switch is in the back lower of the gearbox section if something has got in there and wiped it out. I think I would pull the gearbox out and have a look(not as bad as it sounds) and you could give the sprag a once over while you are in there.
 

·
Registered
Joined
·
997 Posts
i Would only do that if I could guarantee it wouldn’t fire. Maybe pull the fuel pump fuse or the injection fuse but they may have other feeds that would stop the starter motor, or pull off the coil sticks.
 

·
Registered
Joined
·
997 Posts
Because of what you have said and the neutral light now not working. Something must have got into the gearbox. Pull it out and check it is quite easy to do.
 

·
Registered
Joined
·
997 Posts
As Rick says doesn’t sound right. Sorry to say pull it apart again and look at bearings. Check everything is in the correct place by looking at the exploded parts list. Does the alternator spin free by hand? Good luck
 

·
Registered
Joined
·
997 Posts
Oil pump I think. The noise sounds like a bearing or something rubbing. if some debris has got into the sprag clutch it could make a noise and try and spin the starter I suppose.
 

·
Registered
Joined
·
997 Posts
if the clutch is off how do you start the bike? If it just the clutch centre then it will still run crank cams etc, the z25 alternator and sprag but nothing else. Have you tried turning z25 by hand should be more resistance one way as starter and alternator will turn one way and just alternator the other.
 

·
Registered
Joined
·
997 Posts
It’s a puzzle. There are 2 spacer washers on the clutch shaft are they definitely the correct way around? Is there any signs of the oil pump, primary gear and z25 gears being out of line or interfering?
 
1 - 13 of 13 Posts
Top