Benelli Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
Hi everyone, stumped by this.

Bike has not been turned on for a couple of weeks. So I put it on the battery tender for a couple of days.

I turn the key, flip the switch, pumps come on, (all normal so far), hit the starter....nothing....repeat, Nothing.
Side stand is up, bike in neutral, even tried pulling the clutch in, Nothing.
Disconnected negative on the battery for a while; tried again. Nothing.

There is a light click from the left hand side of the bike near the engine when I hit the starter.

Please help !!
 

·
Registered
Joined
·
794 Posts
Do you think it is the solenoid on the starter motor clicking? Check cabling from battery to starter to see if you have a bad connection. Try shorting starter contacts to see if starter turns
 

·
Registered
Joined
·
1,125 Posts
Sounds like what Gbo( Glynn) said to me .. or starter brushes not making contact possibly.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #4 ·
Can you explain what you mean by shorting the starter? Connecting directly from battery?

Also...Battery is at 13.1v right after I remove from the tender. Drops to 12.6 after a couple of presses of the starter button. (But NO cranking...just clicks of a relay).
 

·
Registered
Joined
·
794 Posts
I mean get something metallic to link across the power terminals on the solenoid. You should get a few sparks but if you are quick and firm not too much. The starter should spin.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #6 ·
I mean get something metallic to link across the power terminals on the solenoid. You should get a few sparks but if you are quick and firm not too much. The starter should spin.
Yep this happened, sparked and spun the starter.

Tried the button after that, same thing, just light clicks from near the starter.
 

·
Registered
Joined
·
794 Posts
My solenoid failed just after my last post. Got one hopefully coming hopefully here tomorrow. Have you a multimeter stick it in the top 2 terminals of the 4 way plug(you will have to wiggle them to find a contact) if you have 12v when button and clutch is in, and the starter spins when shorted then solenoid is goosed.
 

·
Senior Member
Joined
·
5,934 Posts
Measure the voltage across the solenoid at the coil contacts (not the back of the plug contact) when you press the starter button. It shouldn't be less than 10V. If it is <10V, chances are you have crook connections somewhere. If >10, the solenoid coil is probably stuffed
 

·
Registered
Joined
·
2,236 Posts
Hi everyone, stumped by this.

Bike has not been turned on for a couple of weeks. So I put it on the battery tender for a couple of days.

I turn the key, flip the switch, pumps come on, (all normal so far), hit the starter....nothing....repeat, Nothing.
Side stand is up, bike in neutral, even tried pulling the clutch in, Nothing.
Disconnected negative on the battery for a while; tried again. Nothing.

There is a light click from the left hand side of the bike near the engine when I hit the starter.

Please help !!
replace the started solenoid (sits just above the alternator) Had to replace it on both my 900s now. I used an aftermarket part from a yamaha tdm 850, direct replacement and cheap as chips on ebay.
 
  • Like
Reactions: Rick67
1 - 10 of 10 Posts
Top