Benelli Forum banner
1 - 20 of 24 Posts

·
Waiting for the AA
Joined
·
54 Posts
Discussion Starter · #1 ·
Bike's getting on for 18months old and since i got it out post winter seems to be suffering a bit.

Idle's fine when first started but once on a run it hovers between 2.5-4k revs.
Makes town riding interesting, as the previous on/off throttle is now just on :D

It's still under warranty so i'll be getting it into the shop and whilst it's there it can also have:

i)a new fuel sender as that's never worked
ii)a new gear lever as the rubbers worn through
iii)a new set of clocks as it resets and the temp gauge does it 160C trick
iv)the top of the master cylinder is corroded :confused: dunno how but all the blacks come off


Anyone else had the same problem re the throttle?
 

·
Registered
Joined
·
1,074 Posts
Not a problem with the high speed running, but number 2, 3 and 4 are all familiar problems that i get on a regular basis. 2003 bike, claims sent to Motogb over a month now and no reply !!
getting a wee bit impatient, but its out of warranty so i guess im at their mercy for the mo.
 

·
ENGLAND FOREVER
Joined
·
1,565 Posts
high running

My RS is the same mate, it runs at 2.5k in gear then slows down to 1.5k in neutral, Colin is the man that has the answer to this.......sure he will reply :bow: :bow: :bow:
 

·
Senior Member
Joined
·
1,841 Posts
Sorry I dont have a possible answer to Jazzys,unless it is a RS ? Still it is under warrenty and should be sorted ok.
 

·
Senior Member
Joined
·
3,085 Posts
yep

mines occasionally does, stoppped in first, it idles fast, I let the clutch out a tad while stopped in gear and it dropped down to 1300rpm straight away, almost like theres a dodgy gear sensor feeding into the ecu or something?
 

·
Waiting for the AA
Joined
·
54 Posts
Discussion Starter · #6 ·
does it in any gear, and in neutral. How is the choke actuated? i'm wondering if something is sticking.
 

·
Senior Member
Joined
·
5,928 Posts
does it in any gear, and in neutral. How is the choke actuated? i'm wondering if something is sticking.
No choke mate. That's part of the injector map....

A/F is enriched by 1.00 @ -10°C. This tapers off to 0.00 at 74°C.
The idle advance tapers off from 23.4° @ -10C, to 1.9° @ 74°C
Idle speed is set to 2000 @ -10°C & tapers off to 1200 @ 74°C

Which begs the question ... Does your temp gauge ever get above 74°C ?
If the sensor is crook, that could explain why yours is idling so high.

It could also be the throttle position sensor needing to be reset.
 

·
Registered
Joined
·
1,680 Posts
iv)the top of the master cylinder is corroded :confused: dunno how but all the blacks come off?
Luckily not had any of your other issues, but I have noticed the master cylinder thing.. :( Mine is about the same age as yours and I'm sure it will be put right at it's next service at Bennetts.. :)
 

·
Registered
Joined
·
1,888 Posts
I am gonna ask a really dumb question now - what / where is the master cylinder so I can check mine and make sure its got plenty of ACF-50 on it?!
 

·
Registered
Joined
·
74 Posts
master cylinder

Hi borat, the master cyliner is that round thing near the brake lever., just noticed mine is losing the black, going to try some plastic coat spray paint.:)
 

·
Registered
Joined
·
1,680 Posts
I am gonna ask a really dumb question now - what / where is the master cylinder so I can check mine and make sure its got plenty of ACF-50 on it?!
Don't worry about it Colin. Laurence will be along soon to sell us posh new billet stuff.. :rolling:
 

·
Super Moderator
Joined
·
7,774 Posts
....did someone say 'billet' :confused:

Here is a pic of the original item just for you Colin:-

 

·
Premium Member
Joined
·
4,429 Posts
Seeing as my tre went with the Rizoma resevoirs i dont have full bling but i'm fortunate that my RS has this ............... so no flaky paint for me :)
 

·
No good with spanners....
MV F3 RC, TNT 899
Joined
·
3,415 Posts
Not a problem with the high speed running, but number 2, 3 and 4 are all familiar problems that i get on a regular basis. 2003 bike, claims sent to Motogb over a month now and no reply !!
getting a wee bit impatient, but its out of warranty so i guess im at their mercy for the mo.
my clocks are the same,do you think its worth getting on to moto gb for a replacement(mines also a 2003)Did you contact them direct?

Question-do the fans cut in when the temp needle on the clocks reach a certain temp or is there a temp sensor somewhere on the cooling system as today for a while engine temp was reading zero!:confused: Didnt stop me having a damned good blast tho:D
 

·
Registered
Joined
·
1,074 Posts
Fred,
I did contact them direct and they couldnt deal that way, they did tell me that there had been no mod claims for my bike, however its had the core plug and tilt sensor done already.
So I was advised to go via a dealer, our friends at Streffords, they have submitted a claim to MotoGB and as I said its been a while now, why dont you try getting them to put one in for you !!

your Question-do the fans cut in when the temp needle on the clocks reach a certain temp or is there a temp sensor somewhere on the cooling system as today for a while engine temp was reading zero!

The fans are controlled by the ECU and come in around 93 degrees depending on how they are set up, I believe it can be altered if required by Tuneboy or Axone device.
 

·
Premium Member
Joined
·
4,429 Posts
I know I know but if i buy some of those rizomas i'll be eating into funds for other things like buying the beer at Roggart, LE , Wife !! (you got anty left Laurence ?)
 

·
Registered
Joined
·
1,888 Posts
mmm those are nice Laurence. I will have to check see what the LE is fitted with. Probably the same as the standard Tre I guess. If so a weekend in Scotland should be enough to corrode the f*ck out of it :rolling:
 
1 - 20 of 24 Posts
Top