Benelli Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
95 Posts
Discussion Starter #1
Curious if anyone has any ideas regarding a minor issue I'm having with my Tornado Tre LE. Now at 300 total miles.

Occasionally the bike stalls when hot. I'll be in 3rd for example getting ready downshift and when I pull the clutch in the bike stalls. Seems to be only when the bike is a bit above 90C. I'm guessing that may be more of a coincidence. Otherwise the bike runs flawless. No hot start issue, etc. Z25 gear and related was changed out a zero miles.
 

·
Registered
Joined
·
95 Posts
Discussion Starter #3
I'll check that.
 

·
Super Moderator
Joined
·
7,757 Posts
This was quite a common problem on some Tornados. Increasing the tick-over by a couple of hundred revs should help to stop it. You can only do this on the ECU so you will need either TuneEcu or an Axone to adjust it.
 

·
Registered
Joined
·
95 Posts
Discussion Starter #5
Thanks!
 

·
Senior Member
Joined
·
5,836 Posts
This was quite a common problem on some Tornados. Increasing the tick-over by a couple of hundred revs should help to stop it. You can only do this on the ECU so you will need either TuneEcu or an Axone to adjust it.
I had an RS that was idling at around 13:1. To fix the stalling I reduced it a little, to around 12.5:1 and raised the idle speed by 100 rpm. No complaints since.
Mind you, her partner had no problem with it, and neither did I, so it depends very much on how you ride it. I tend to keep the throttle cracked just a little when throttling off & de-clutching.
 

·
Registered
Joined
·
95 Posts
Discussion Starter #7
I'd like to think that is the issue. I was reminding myself to keep the rpm up when pulling in the clutch but it cut out almost instantly several times today.
 

·
Registered
Joined
·
82 Posts
Implementing above suggestions together with moving the air intake temperature sensor to a location near the front lamp and syncing butterflies cured the issue for my standard Tornado TRE
 
1 - 8 of 8 Posts
Top