Benelli Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi,

I just bought a Trek 2008 and i have this strange issue sometimes when starting or shutting down engine i hear this hard hit... anyone have a clue what can it be? One more question, where can i get a obd cable for my trek any suggestions?

thanks
 

·
Registered
Joined
·
1,082 Posts
Maybe you starter motor is damaged.

Obd cable dont work with trek.

If you have a walbro ecu you need a rs232 cable kit have a look at tuneecu.com there are infos how make a cable kit or buy one.

There are 2 versions out there

1. rs232 kabel with adapter (sometimes connections is a little unstable)

2. Usb/amp cable kit (better solution)

If you want a set let me know I sell them if wanted.

Gesendet von meinem SM-P905 mit Tapatalk
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Maybe you starter motor is damaged.

Obd cable dont work with trek.

If you have a walbro ecu you need a rs232 cable kit have a look at tuneecu.com there are infos how make a cable kit or buy one.

There are 2 versions out there

1. rs232 kabel with adapter (sometimes connections is a little unstable)

2. Usb/amp cable kit (better solution)

If you want a set let me know I sell them if wanted.

Gesendet von meinem SM-P905 mit Tapatalk
thx for info... yes im intrested i buying cable... you can send my message with price and details... all i need to do is check is my ecu i walbro... Also i see that you are in Munich i have a friend there who could pick it up and send it to me in croatia...
 

·
Registered
Joined
·
1 Posts
Hi,

I just bought a Trek 2008 and i have this strange issue sometimes when starting or shutting down engine i hear this hard hit... anyone have a clue what can it be? One more question, where can i get a obd cable for my trek any suggestions?

thanks


Hi,have you fix the problem with kick? it looks i have the same problem... THX
 

·
Senior Member
Joined
·
6,011 Posts
i have this strange issue sometimes when starting or shutting down engine i hear this hard hit..
Same thing sometimes happens with my Tornado, but only at shutdown. It depends where in the cycle the crank stops. There are three (I think) natural resting points dependant on the cam lobes. If it stops between them, the crank will then rapidly move to one. If it means going backwards, it will, and that's where the clunk comes from. The cam chain is running backwards and not held tight by the crank.

That's my theory. I may be wrong..
 

·
Registered
Joined
·
1,215 Posts
Yes same noise happens occasionally on my bike . I'd put the noise down to the engine reversing back slightly at shutdown and maybe moving the sprag clutch a little . Freaks me out lol. Pulling the clutch in on shutdown helps I found
 

·
Registered
Joined
·
45 Posts
Yes same noise happens occasionally on my bike . I'd put the noise down to the engine reversing back slightly at shutdown and maybe moving the sprag clutch a little . Freaks me out lol. Pulling the clutch in on shutdown helps I found
I think it is this trait that causes z25 / clutch retaining nut to loosen and alternator rubbers to disintegrate.......any opinions?
 
1 - 10 of 10 Posts
Top