Benelli Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
78 Posts
Discussion Starter · #1 ·
Hi all,

I have an 07 CR and the engine warning light has come on a couple of times in the past week. While it resets after two restarts understandably I have some concerns. The local dealer needs to update diagnostic software for the 07 which will happen in the next couple of weeks.
In the interim has anyone seen this before and what are possible causes? I suspect it may be temperature related (sensor fault?) since its only happened on very warm days (> 35oC/95F).

Im still riding since its my primary transport but have some concerns.

AJ
 

·
Registered
Joined
·
209 Posts
Hi,

Had the same issue with mine. It got to the point where it would turn off for an hour or two then be back on for the next two days. The engine appeared to be fine and the mechanics said it was a known issue. They updated the maps and it stopped happening.

However ! That doesn't mean there's nothing wrong with your CR. So get it to the mechanics to check out. If you have any doubts, give Kelvin at a1 motorcycles in Ringwood Melbourne a call. He looks after mine.

ciao
Derek
 

·
Registered
Joined
·
73 Posts
My 2006 TNT Sport had the same fault with no obvious symptoms and would reset after 2 starts. Since Clayton loaded the 2007 map I have had no more faults in 6 months. Hope this reduces your worries till you have it checked.
Cheers Mike.
 

·
Registered
Joined
·
78 Posts
Discussion Starter · #6 ·
Thanks all. First up yes Im in Aus, Melbourne to be exact. Im having it diagnosed Monday (Jan 7th) so Ill report back once I know the cause. If I continue having issues Ill certainly look into the TuneBoy.

It happened again on Dec 31st (42oC) and again 1st Jan (40oC) so my suspicsions about being temperature related are firming up. Given mine is the 07' I would assume its running the current mapping but Ill ask the question when I drop in on the dealer tomorrow.

Just in passing, has anyone else had quality issues with their bike? The mount on my rear hugger broke (warranty job) and the rear indicator broke while I was riding it (mate was following me and saw it happen).

Regards,

AJ
 

·
Senior Member
Joined
·
3,085 Posts
nope

My Tornado Rs has been awesome since i got it, only some low rev fuelling surging and rear brake squeal, and thats it
 
1 - 7 of 7 Posts
Top