Benelli Forum banner
41 - 60 of 69 Posts

·
Registered
Joined
·
1 Posts
900 torando service manual

Streuth! I wasn't aware of this. It may have happened when I changed provider. .....

Just had a look at it. The files were in Dropbox which I had recently cleaned up - removing them :doh:
They've been in Google Drive all along, and that's where they will stay, so I've changed the links to there.
I've checked that it works for me.
Would you like to check that it works for everyone else Justin?
hi please update link ,when try to download torando 900 service manual drop box window opened with this messege
404
That file isn’t here anymore
Someone might’ve deleted the file or disabled the link.

Learn more

thanks pls help me :eek:
 

·
Super Moderator
Joined
·
7,814 Posts
Discussion Starter · #46 ·
I'm still having problems with the dropbox links I'm afraid.

PM me your email address and I'll send you it
 

·
Registered
Joined
·
126 Posts
Hi Lawrence i dont think the links for the 900 work anymore :(




 

·
Super Moderator
Joined
·
7,814 Posts
Discussion Starter · #51 ·
Yeah,

Dropbox screwed up my account and despite contacting them on several occasions they have not fixed it :mad:
 

·
Registered
Joined
·
13 Posts
2014 trek amazonas manual

hi
im new to the site. i have a 2014 amazonas with electrical problems. i have 2 manuals 1 is a 2009 trek manual the other is tre k to 2014 supplied to me by my local benelli dealer scooter style in noosa thank you ruth.
problem is neither wiring diagram is exactly the same as my original wiring any ideas??

the problem with the bike is that when the key is on i only have power to the park lights/indicators /brake lights and horn, nothing at all happening at the instrument panel though all the switches have been checked and ok the diodes are ok, so save having a instrument panel to substitute im stuck.

any guidence greatfully recieved

an owners manual for this year model might be helpfull

thank you
ken
 

·
Registered
Joined
·
1,211 Posts
Hi .
There may be a ground wire not connected to the battery .
There should be two of them .
It has happened to me when I changed my battery lol.
It may also be one of the relays or the main fues by the starter relay .
I may be completely wrong as well ...
 

·
Super Moderator
Joined
·
7,814 Posts
Discussion Starter · #59 ·
Well many thanks to Andres (Arbm15) for hosting the manuals.

I have now replaced all the URL's so they should now work again.
 
  • Like
Reactions: Arbm15 and JJdeHaan

·
Registered
Joined
·
74 Posts
Nice work that the manuals are online again.

unfornaly i miss a TnT 1130 Century Racer (not the CR because they have lower clip-ons) manual model 2012
a lot off the TnT 1130 manuals are the same butt there are still little differents in my bike and the latetest 2009 manual(s)

Butt nice to have it back on line
 
41 - 60 of 69 Posts
Top